
Chapter 1
Introduction to MediaPaint

Introduction
Welcome to the exciting world of special effects and thank you for choosing Strata Inc.’s MediaPaint. The magic 
of creating special effects on film and video has become one of the fastest growing art forms in today’s market. 
These special F/X (as they are called in the movie industry) enthrall and awe the viewer, and provide the spark 
that powers the creative F/X artist. But creating truly amazing special F/X has remained out of reach for most 
amateur movie editors and multimedia designers due to the high cost of special F/X hardware - until now.
Strata’s MediaPaint gives you the ability to create special movie effects such as laser blasts, light sabers, 
transporters, rotoscoping, and other movie magic at an affordable price. The package incorporates many of the 
same techniques to create effects that, until now, could only be found in productions from expensively equipped 
special effects studios.
This innovative software package provides the tools for creating movie magic at home or in the office. However, 
while Strata Inc.’s MediaPaint supplies the tools you need to bring your ideas to life, you must provide the 
imagination and creativity.
This chapter of the User Manual will provide an introduction and overview of MediaPaint’s capabilities, 
information on registration, and a list of basic tools and features.
For system requirements and installation of MediaPaint, see the    Quickstart brochure included with this release.
Before you begin
The first step with this, or any program you purchase, is registering your software. This involves completing and 
sending in the Registration Card found in your MediaPaint package.
The benefits of registering your software:

· Free technical support
· Software updates
· Special pricing on software upgrades
· Strata’s quarterly newsletter

Personalize your software
The first time you launch the MediaPaint application you will be asked to enter your name, organization, and 
product serial number. While you are not required to enter anything in the organization field, you MUST enter a 
name and your product serial number.
The product serial number can be found on the Registration Card included in your MediaPaint package. Enter this
number exactly as it appears. You will not be able to run the application without a valid serial number. You will be
prompted to reenter the number if it is improperly entered the first time.
Once the information is correctly entered, it will be permanently encoded in the application and will appear on 
the MediaPaint start-up screen each time you launch the program. You will not have to enter the information 
again unless you delete the file “MediaPaint Preferences.rsr.”
Technical support
Strata Inc.’s technical support group is available to all registered users should they have questions about the 
software. However, before calling the Technical Support phone number, please consult the appropriate chapter of
this manual to see if the information you need is there.
Remember, you must be a registered user to receive technical support. So if you haven’t sent in your registration
card yet, you may want to take a few minutes to complete the card now.
Be sure to have your serial number handy when you call Strata’s support lines. The product serial number is the 
only means of identifying registered users.
Strata Technical Support:        (801) 628-9751
Fax: (801) 628-9756
e-mail:                                          support@Strata3d.com    



MediaPaint concepts
MediaPaint allows you to add special effects and enhancements to movie files without altering the original. This 
nondestructive editing technique is an important concept in the MediaPaint package and puts MediaPaint in a 
class of its own among special movie effects software.
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Movie files
Movie files can be created with a number of software packages, including MediaPaint, and played back in a 
manner similar to a standard VCR you may use to watch movies in your home. You can also record a movie with 
a video camera and digitize a version of the film to your computer as a movie file. There are numerous packages
that allow you to digitize videos.
Once a movie file has been opened in MediaPaint, you are free to use all or part of the movie in your production. 
This is done by setting the In and Out points to specify the beginning and ending frames of your work area. 
Again, this gives you total control of your work environment without modifying or damaging the original movie.
MediaPaint uses the SMPTE (Society for Motion Picture and Television Engineers) standard for specifying time 
code. This method of frame-by-frame tracking numbers the frames according to the actual time from the first 
frame in the movie.



Layers
When a movie file is opened in MediaPaint, the program places a transparent Paint layer over the movie. This 
layer, called the Paint layer, is the work environment where all the painting is done. The Movie layer, where the 
original movie is located, is read-only and cannot be modified. 



Stencil
A third, pseudo-layer is also available in MediaPaint. It is the Stencil layer and is used to hold a movie or image 
file that can be applied to the Paint layer just like any other color in the Color palette. With this powerful option 
you can composite multiple layers of video, remove wires, make a person appear to float across the movie 
screen without touching the ground, or any number of other special effects.
You should note that the Stencil layer is actually not a layer at all. Rather, it is a memory buffer where the Stencil
file is held until you paint it onto the Paint layer. However, because of its similarity to the functioning of other 
layers used in MediaPaint, the buffer will be referred to as the Stencil layer in your MediaPaint reference 
materials.



Paint
Paint is classified as anything in the Paint layer. The paint can be a simple color or a graphic image from the 
Stencil layer and can be applied using traditional painting tools or specialized plug-in tools. Once applied, Paint 
can be modified to change its opacity, softness, sharpness, color, and a number of other characteristics through 
built-in and third-party plug-in tools and filters.
Paint can also be applied automatically to all frames of the movie as you step through the frames one at a time 
or by entering a range of frames. You can also record painting actions while the movie is playing to create effects
such as animated handwriting.



Transparency
MediaPaint supports both Alpha channel and Chroma Key technology. Both these technologies allow you to 
create and adjust transparency in your projects.
Chroma Key 
The Chroma Key technique is similar to the bluescreen method used in the television and movie industry. It 
allows you to key colors in a movie or image stored in the Stencil layer. You can then adjust the opacity of the 
keyed colors in the Stencil layer image to make those colors appear transparent when the stencil is painted onto 
the Paint layer. This technique allows images in the movie layer and any paints already applied to the Paint layer 
to be seen through the keyed areas of the stencil paint when it is applied to the Paint layer. You can also adjust 
the range of colors affected in the Chroma Key process.
The Chroma Key feature actually creates transparency where none existed before.
Alpha channel
Alpha channel technology allows you to adjust the transparency of all paint used in MediaPaint. All paints used in
the application have the standard RGB (Red, Green, and Blue) color channels, each of which can be adjusted 
from fully off to fully on. In addition, MediaPaint assigns an Alpha channel to each color. The Alpha channel can 
be adjusted in the same manner from fully transparent to fully opaque. Varying the levels of transparency can 
create a ghostlike effect when the paint is applied to the paint layer.
The Alpha channel applies a level of transparency to the actual paint and can be used throughout the program. 



Palettes
You can paint on the Paint layer using a variety of built-in tools to create the look you want. 
These tools are easy to find and include tool, color, brush, and pattern palettes. Some of these palettes can be 
customized to meet your own needs.
MediaPaint also allows you to build your own library of palettes so you don’t have to create your favorite painting
elements for each new project. These palettes can be loaded into the application as they are needed.



Tools and features
The list of tools and features in the MediaPaint software package is extensive and includes many of the features 
found in professional special effects studios. MediaPaint features include:

· Standard draw/paint tools - MediaPaint offers a full compliment of the standard tools found in most draw and 
paint software.

· Self-generating particle tools - Easily create unique effects including PixieDust, BabyBoom, SpinOut and 
Squiggle.

· Layer control - You have control over the working environments in MediaPaint.
· Nondestructive editing - Files imported into the Movie layer are read-only and cannot be edited or modified.
· Auto Copy function - Auto Copy allows you to copy paint as you step from one frame to another.
· Anti-aliasing function - MediaPaint can create anti-aliased text and shapes.    This feature compares colors 

pixel by pixel and ensures variations are properly handled to create a smooth transition.
· Built-in filters - The software package features a variety of filters including Blur,    Brightness-Contrast, Color 

Gradient, Diffuse,    Dotlet, Fade, Falloff, Hue-Saturation, Invert, Lens, Mosaic, Sharpen, Swirl and Wave.
· Plug-in tool and filter support - MediaPaint supports most third-party plug-in tools and filters, which allows 

easy software upgrades.
· Pressure sensitive tablet support - Most pressure sensitive tablets can be used with MediaPaint.
· Special Paste functions - Along with standard paste functions, MediaPaint offers special options to allow you to

paste paint on one frame, a range of frames, or the entire project.
· Control over project length - MediaPaint allows you to limit your project to any range of frames by changing 

the In and Out points.



Chapter 2
Working With Documents

Introduction
This chapter will provide information you need to begin creating your own projects with MediaPaint. MediaPaint is
unique in that it will preserve your movie files without the chance of accidentally destroying them. In fact, you 
never alter your original movie. All painted special effects are applied above the movie on the Paint layer. You 
can then save your document as a new movie file. 
It is important to understand the concept of MediaPaint’s different layers. All MediaPaint documents contain two 
layers and one pseudo layer: the Paint layer, the Movie layer, and the Stencil layer.
Paint Layer
This layer contains all paint that is applied to your document. All changes to your project are made at this level. 
You can choose to paint in the Paint layer with a movie in the background, or you may decide to create your own 
movie in the Paint layer. 
Movie Layer
You can import a movie or image file to the Movie layer, which will be shown in the background while you are 
working on your project in the Paint layer. You cannot change anything on the Movie layer, but you can copy 
portions of the Movie layer to the Paint layer and make changes to the copy.
Stencil Layer
A third, pseudo layer is also available in MediaPaint. It is the Stencil layer and is used to hold a movie or image 
file that can be applied to the paint layer just like any other color in the Color palette. You should note that the 
Stencil layer is actually not a layer at all. Rather, it is a memory buffer where the stencil image is held until you 
paint it onto the Paint layer. However, because of the similarity between this buffer and the functions of other 
layers used in MediaPaint, the buffer can be thought of as a third layer.



Open Document
When you launch MediaPaint for the first time, the New dialog box will be displayed. This is how the program will 
begin each session unless you change the settings in the Preferences dialog.
Documents can also be opened by selecting the New or Open commands from the File menu. There are, 
however, differences between the two methods.
Use the New command to:

· Create a new document with a movie or image file loaded in the Movie layer.
· Create a new document with nothing loaded in the Movie layer.
· Open an existing MediaPaint document.

Use the Open command to:
· Open a movie file for viewing or painting.
· Open an existing MediaPaint document for painting and editing.

You can change the way MediaPaint starts up each time you launch the application. Instead of displaying the 
New dialog and allowing you to open a movie to begin painting on, you can choose to have MediaPaint ask you 
for a frame size only, or default to a frame size you preset. See the discussion on Setting Preferences later in this
chapter.



New Document
You can create a MediaPaint movie or still image entirely from scratch using hand-drawn graphics. You can 
import a movie later if you want by selecting Import from the File menu. After launching MediaPaint for a new 
session the New dialog will be displayed (if the application is already running, select New from the File menu to 
open the New dialog).
Creating a New document
1. Select a document size. 
This option will determine the size of each frame in the document you are creating. 
2. Click on the New button in the New dialog box. 
A new, blank document window will open. There will be nothing on the Movie layer at this point. 



Open an image to paint on
You can begin your project by opening a movie or image file to paint on. Again, the New dialog is displayed when
you launch MediaPaint. If you are already working in MediaPaint and you want to begin a new project, select New
from the File menu.
Selecting an image to paint on
1. Select a movie or image file from the list of file names in the New dialog.
Unless you are creating a movie or still image entirely from hand-drawn graphics, you will want to select a movie
or still image to paint on for your new document
2. Look at the preview of the selected document in the preview area.
If no preview appears, make sure you have checked the Preview option. 
The frame size of the document is determined by the file you select to place in the Movie layer. When you click 
on a file, the frame size will default to the size of the movie or image file selected. You can override this setting 
by highlighting the file you wish to open, then selecting the frame size you want. If the frame size is different 
from the movie size, only the frame will be scaled. The size of the movie will not change. You can change the 
position of the movie within the frame to view a different portion by choosing Set Movie Position from the Layout 
menu and dragging the movie to the position you want.
3. Click the Open button.
The New dialog box will close and MediaPaint will create a new document using the movie or still image you 
selected.
You can also open a movie to paint on from the Open dialog, but you must click the For Painting radio button. 
However, opening a movie in this manner prevents you from selecting a frame size for your document. The 
frame size of the new document will default to the size of the movie.



Import a movie
If you create a new document without selecting a movie to paint on, you can use the Import command to load a 
movie or still image. You should note that importing a movie will replace any movie already loaded to the Movie 
layer.
Importing a movie
1. Choose Import from the File menu.
The Import dialog box will appear.
2. Select a movie or image file from the list of files in the Import dialog.
You may be able to preview the selected file before committing to the operation using the preview option. If no 
preview appears when you select the file, make sure the Preview box is checked.
3. Import the selected document to the Movie layer.
Click on the Movie radio button if it is not already selected. 
4. Click on the Import button.
The Import dialog box will close and MediaPaint will import the selected movie or still image to the Movie layer.
When a movie is imported, the current compression settings of your document will be retained.



Open a MediaPaint document
You can open an existing MediaPaint document with the Open command to edit your document. You can open 
your MediaPaint project document from the New dialog at start-up, or select New or Open from the File menu if 
the application is already running.
When you open a MediaPaint document, any movie or image file in the Movie layer and any stencil in the Stencil 
layer will automatically be loaded. You will be asked to locate the movie or stencil files if they have been moved 
since the last time you worked with the document.
If you select Open from the File menu while working in MediaPaint, the radio button at the bottom of the Open 
dialog is automatically set to the For Painting option. 
You can have only one document opened For Painting at a time. Opening another MediaPaint document will force
the currently active document to be closed. MediaPaint asks if you want to save the current document before it is
closed.



Movie Position
If you use a movie or still image in the Movie layer, especially one with a frame size smaller than your document 
size, you may want to reposition the image in the document window.
Setting the movie position
1. Choose Set Movie Position from the Layout menu. 
The border of the movie will be highlighted and a ghost image of the movie will appear on top of the Paint layer. 
2. Move the pointer over the document window.
The cursor will change to the Grabber hand. 
3. Click-and-drag the movie to position it where you want it.
The border of the movie and its ghost image both give visual feedback.
4. When the movie is properly positioned, click outside the image border or press the Return or Enter key.
All frames in your document will reflect the image’s new position.



The Filmstrip
The Filmstrip displays the contents of each frame in your document. It contains all the paint on the Paint layer 
and any movie loaded to the Movie layer. To view the Filmstrip, select Show Filmstrip from the View menu.
In Point
The In point marks the beginning frame of your project. You can change the In point to a new position in the 
filmstrip by dragging it with the cursor or using the Set In Point command described later in this chapter.
Out Point
Set the Out point to mark the end of your project. When you move the Out point to the right to create new 
frames in your document, the new frames will display the current background color, or repeat the last frame of 
the movie if if it is at the end.
Active Frame
The active frame is the frame currently displayed in the document window. On the filmstrip, the Time Code label 
area above the active frame appears highlighted. 
Selected Frame
When you click on a frame in the filmstrip, that frame becomes the selected frame and remains selected until 
you click on a different frame. Selected frames are displayed with a black-and-white selection border. You can 
have more than one frame selected at a time. Use the Shift key to select a range of frames. 
You should note that the selected frame is not necessarily the active frame. When you click on a frame in the 
filmstrip, that frame becomes the active frame as well as the selected frame. If you activate the document 
window and use the Step Forward or Backward button on the Movie Controls palette, the active frame 
(recognized by the dark gray band along the Time Code bar) will change to the frame currently displayed in the 
document window, but the selected frame will not change.
Time Code Display
This shows the exact location of the frame in the filmstrip. The time code shown is in the SMPTE format:
Time Interval Display
This shows you the time interval in which the frames are displayed. In the previous illustration, the Time Interval 
Display is set at five frames. Therefore, every fifth frame is shown. Setting the Time Interval Display to one 
second would display the first frame of each second’s worth of frames (at 15 frames per second, every fifteenth 
frame would be displayed). By dragging the thumbnail to the right or left, you can select a time interval to 
display the frames in your filmstrip. An interval of 30 seconds or higher will only display times.
Scroll Bar
Use the arrows at either end of the Scroll Bar to scroll to any frame of the movie in the Movie layer. You can 
increase the scrolling speed by holding down the Alt key while scrolling. Note that when you scroll with the Alt 
key depressed, the Time Interval Display changes to a Time Code Display. This is helpful when working with large
files. You can also drag the slider on the scroll bar to move to any location on the filmstrip.
Once a movie has been imported or opened, it resides on the Movie layer. It becomes the background for your 
Paint layer and is displayed in sequence in the Filmstrip window. If an image file was opened, that image appears
in each frame of the filmstrip. 
When you first open the Filmstrip window you will notice that it becomes the active window. Also, as long as the 
Filmstrip window is the active window, the tools in the Tool palette will be dimmed. You cannot paint on the 
frames of the filmstrip itself. To make the document window active again, simply click anywhere in that window. 
Define the Length of your Movie
The In and Out points on the filmstrip define the beginning and end of your work area. This may be different than
the actual length of the movie loaded in the Movie layer.
Any frame in the filmstrip can contain paint even if it does not reside within the range of the In and Out points. 
However, when you save your project as a movie, only the frames within the range of the In and Out points will 
be saved. 
Setting the In and Out points

· Set the In point
To set the In point of your document, slide the In point marker on the filmstrip to the frame you want to use as 
your first frame; or, select the frame on the filmstrip you want to designate as the first frame of your movie and 
choose the Set In Point command from the Movie menu.

· Set the Out point
To set the Out point, slide the Out point marker on the filmstrip to the last frame you want included in your 
movie; or, select the frame on the filmstrip you want to designate as the last frame of your movie and choose 



the Set Out Point command from the Movie menu.



Auto Advance Out Point
Select this option from the Movie menu to automatically advance the Out point as you work on your project. As 
you advance forward beyond the original Out point, the Out point will advance forward with you. You cannot 
advance beyond the Out point when the option is turned off.



Open for Viewing Only
When you want to open an existing movie or still image for viewing only, use the Open command. Select the 
movie or image file you want to view and click on the For Viewing radio button. 
Once the movie opens you can view it by using the controls at the bottom on the viewing window. The viewing 
window controls will differ slightly depending on the type of movie you are viewing. Any sound track that existed 
in the original movie will be played with the movie while in this mode. 
You cannot paint on, or in any way alter, a movie that has been opened For Viewing. While only one document 
can be opened For Painting at a time, you can have multiple movies open For Viewing. When the active window 
contains a movie opened For Viewing, none of the tools are available.



Presentation Mode
Presentation mode allows you to display your movie or still image in the center of your screen against a black 
background. This mode is available only when you have opened a document for viewing only.
To access Presentation mode, select Begin Presentation from the Movie menu. A dialog box will be displayed with
instructions for playing your document. 

· To single step through frames, click the mouse button or press the left or right arrow keys.
· To start and stop playing, double-click the primary    mouse button or press the space bar.
· To play at half-speed, press and hold down the primary    mouse button or the Shift key.
· To end the presentation, press Ctrl + . or the Escape key.

Sound tracks recorded with the original movie file will be retained in MediaPaint and can be played back in the 
Presentation Mode or when a movie has been opened for viewing only. The sound track will be saved with the 
final movie file, but you cannot edit the sound track in MediaPaint.



Import a Stencil
You can import either a movie or image file into the Stencil layer. If an image file is imported into the Stencil 
layer, the image appears in every frame of the Stencil window. The stencil feature permits you to use a loaded 
movie or image file as a color you can actually paint right onto your movie.
Loading a stencil
1. Choose Import from the File menu.
You must have a document open to import a file into the Stencil buffer. The Import dialog will appear when you 
choose the Import command.
2. Select a movie or still image document from the Import dialog. 
If no preview appears in the preview area when you select the image file, make sure the Preview checkbox is 
enabled. 
3. Import the selected document to the Stencil layer.
Make sure the Stencil radio button is turned on (this is the default). If it is not turned on, the image will be loaded
to the Movie layer, replacing any previously existing file in that layer.
4. Click the Import button.
The Import dialog will close and the selected image will be loaded to the Stencil layer.



Set Stencil Alpha
Once a stencil has been imported, you should change the alpha (level of transparency) of the stencil paint. To 
change the alpha, select Set Stencil Alpha from the Layout menu. 
Fixed Alpha
You can set the alpha level of the stencil from 0 to 255. The higher the value, the more opaque the stencil paint 
will be. Lowering the value increases the transparency of the stencil paint. This option applies alpha levels to the 
entire image.
Chroma Key
Clicking this radio button allows you to key various colors to create areas of transparency in the stencil paint. 
Please refer to the Advanced Features chapter of this manual for information on using the Chroma Key feature.
Native Alpha
Select this option to retain the level of alpha originally saved with the image.
Invert Alpha
Check this option to reverse the alpha data. Areas of transparency will become opaque and opacity will be 
converted to transparency.
Scale Alpha
This option allows you to adjust the transparency of the image on a global scale. When you scale the alpha level 
with this option the entire image is affected.



Setting Stencil Position
You can change the position of the stencil in the same manner as changing the movie position. However, 
because of the special nature of the stencil, you can change its position as often as you want without affecting 
previously applied stencil paint. When you draw with stencil paint, the image you lay down on the Paint layer 
exists in your document as paint. You can change the stencil position after laying down a layer of stencil paint 
and paint again. The previously applied stencil paint remains as it was painted and the new drawing reflects the 
current stencil position.



The Stencil Window
The Stencil window has a time interval and time code display just like the Filmstrip. However, there are no In and
Out points in the Stencil window. To view the Stencil window, choose Show Stencil from the View menu. The 
stencil will be displayed in a filmstrip-like window. 
Active Frame
The Stencil Window’s Time Code label area will be dark gray over the active frame. If you apply stencil paint in 
the document window, the paint is sampled from this frame and placed in the current Paint layer frame of your 
project. You can change the active frame of stencil paint at any time by clicking on the desired frame while the 
Stencil window is active. Using this method, you can apply stencil paint from more than one stencil frame to a 
single frame of your document.
Time Code Display
This area of each frame in your stencil window corresponds to the exact location of the frame in the filmstrip. 
The time code shown is in the format: hours : minutes : seconds . frame. 
Time Interval Display
This shows you the time interval of the frames in the stencil window. In the Stencil window illustration, the Time 
Interval Display is set at 10 frames. Therefore, every tenth frame is shown. Setting the Time Interval Display to 
one second would display the first frame of each second’s worth of frames (at 15 frames per second, every 
fifteenth frame would be displayed). By dragging the thumbnail to the right or left you can select a time interval 
anywhere from one frame to two hours. 
Scroll Bar
Use the Scroll Bar to move to any frame in the Stencil layer. 
When you paint with Stencil paint, the stencil image is copied from the active frame of the stencil window and 
applied to the current frame in the document window. The current frame in the Stencil window automatically 
advances or steps back when you move to another frame in your document using the navigation controls or 
menu commands.
Remember that Stencil functions as paint. If you import a movie into the Stencil layer, you can create video-in-
video effects. Stencil paint allows you to use a movie as dynamic paint that changes over time, in effect, 
stenciling one video on top of another.



Alpha Channel Output
Choose the Alpha Channel Output command from the File menu to specify how you want the Alpha Channel 
saved. 
Scale Alpha Out
Turning this option on will scale the color to the output file. Deselecting this box will turn off the current alpha 
scale so the file can be accurately scaled when opened in other applications.
Invert Alpha Data
Because definitive standards for setting alpha channels have not been firmed up throughout the computer 
graphic world, software packages may recognize transparency differently. To ensure you can use your completed 
MediaPaint image or movie in various formats, Strata engineers have included the Invert Alpha Data command.
Before setting this option, check the User Manual of the software package in which you intend to open your 
completed image or movie to determine which method of alpha recognition is used by that program. 
Check the User Manual of the software package you intend to open your saved image or movie in to determine 
which method of alpha recognition is used by that program before setting this option.



Compression Settings
When you save your project as a movie, you have several different options for compression settings.
Which compression method is best for you depends on the type of video being compressed, and your need for 
quality vs. contraints on file size. Selecting a higher quality setting produces a more realistic image but uses 
additional disk space. Experimentation will help you find the best method for your needs. 
When you choose Compression Settings from the file menu, a compression dialog will appear.    Your choices for 
AVI compression depend on which codecs are installed on your computer.
Changing your compression settings in the dialog changes the default settings for saving movies. However, you 
can also change the settings when saving your work by clicking Options in the Save or Save As dialog box.
Video for Windows (AVI) settings
1. Choose Compression Settings from the File menu.
The Video Compression dialog will appear.
2. Select a compressor from the pull-down menu.
Several software compressors are available. This list will vary based on the codecs installed on your computer. 
Each compressor is designed for a specific use, and using the proper compressor for your needs can improve the
playback performance of your final    movie. 
3. Use the slider bar to set the quality.
Selecting a higher quality setting produces a more realistic image but uses additional disk space.
4. Enter a value for determining how often to create key frames. 
Key frames are stored as complete frames. All other frames contain only changes in the image from the last Key 
frame. By storing only the differences between frames rather than a full image every frame, the file size is 
substantially reduced and the play back is faster. While increasing the number of key frames increases the 
accuracy of the playback, it also results in a larger file size and could affect how smoothly the movie plays back.
If you do not want to create any key frames, the Key Frames checkbox should not be checked. In this case, only 
the first frame will be saved as a complete frame.
5. Enter a value for data rate, if available and needed.
The type of media you will be playing your movie on will help determine the frame rate needed. 
6. Click Configure for additional settings, if available.
This option is not available on all compressors.
7. Click Preview for an expanded dialog box containing a preview window.
Use the preview function to help you decide on the proper compression settings for your needs.



Set Frame Rate
Select Set Frame Rate from the File menu. This determines how many frames will be played in a single second 
when you play back your saved movie. It also affects the time code displayed in your Filmstrip and Movie 
Controls windows. This is different from the recording frame rate you may set on the Movie Controls palette.    
You should note that hardware restrictions could affect the playback quality of your movie. 



Save your work
It is always a good idea to save your document often. In addition to saving often, it may well be worth the extra 
effort and disk space to save it under different names with the Save As command as you progress through your 
project. This allows you to revert back to an earlier version of your project.
Saving a MediaPaint document
1. Choose Save from the File menu.
If the document you are saving has been saved previously, MediaPaint saves your changes to the document and 
you can continue working.
If the document has not been previously saved, the Save As dialog will allow you to enter the name of your 
document and specify where on your hard disk drive to save the file.
2. Select MediaPaint document from the file type pull down list.
This tells the application to save the document as a MediaPaint file.
3. Click the Save button.
MediaPaint saves your entire document, including any paint you have applied to the Paint layer, a reference to 
any images in the Movie or Stencil layers, and the In and Out points you have specified.
Saving a movie
When you save your document as a movie file, you have the option to change some of the settings. 
1. Choose Save As from the File menu.
This will prompt a dialog allowing you to enter a name for your document and select where the file will be saved.
2. Select Video for Windows (*.avi) from the file type pull down menu.
3. If you want to change the Compression options, click the Options button.
The movie will be saved with the compression settings you defined in the Compression Settings dialog. You can 
still change them before you save your project as a movie file through the Save dialog’s Option settings.
4. Click the Option dialog’s OK button.
You will return to the Save As dialog where the options you selected are listed at the bottom of the dialog.
5. Click the Save button.
Saving a picture 
There may be times when you want to save a single frame of your project as an image file. To do this, simply 
make the frame you want to save the active frame in the document window and choose the Save As command 
from the File menu. Enter a name for your file in the dialog and select the desired image file type from the pull 
down menu.



Revert
Select the Revert command from the File menu to ignore any changes made to your document since the last 
time the document was saved. The Revert command is available only when a document has been previously 
saved. Before executing the Revert command, MediaPaint displays a warning that Revert cannot be undone. 
Click the Proceed button to continue, or the Cancel button to return to your current document.



Set Preferences
You can change many of the default settings for MediaPaint to suit your needs. 
Setting the preferences
1. Choose Preferences from the Layout Menu.
The Preferences dialog will be displayed.
2. Select an option for creating new projects.
Prompt for a movie
Selecting this option will present the New dialog every time you create a new document. This allows you to 
select a movie or still image file to place on the Movie layer at the beginning of your project. You can also select 
a new document with no movie or still image on the Movie layer.
Ask for dimensions only
This option will present a limited New dialog every time you create a new document. This dialog only asks you 
for the dimensions of the new document and does not ask you to select any files for the Movie layer. Even when 
this option is selected, you can still import files to the Movie layer using the Import command in the File menu.
Use preset dimensions
This option allows you to preset the frame size for new documents. When you launch MediaPaint with this option 
selected an empty document window opens with nothing on the Movie layer. You can import a movie or still 
image by selecting the Import command in the File menu.
3. Select the Palette window preferences.
You can decide where you want your floating palettes to appear each time you launch MediaPaint. Click 
Remember Current Positions to have MediaPaint remember the last position of each floating palette when it 
starts up again, or click Use Standard Positions to use the preset position for each palette.
4. Select the Text menu preferences.
You can group the Font, Size, and Style menus together under one menu named Text, or you can leave each text 
menu as a separate item on the menu bar.
5. Check the Use Hot Keys checkbox if you want to use the Hot Keys with the tools in the Tool palette.
See Appendix A for a complete list of Hot Keys and keyboard modifier keys. 
6. Check the Auto Scroll checkbox to enable automatic scrolling.
When you size your document window (with the size box in the lower right-hand corner of your document 
window) so the entire frame is not visible, the Auto Scroll function allows you to paint beyond the frame window. 
MediaPaint automatically scrolls the frame within the document window for you as you paint. If Auto Scroll is 
turned off, you can still paint beyond the visible portion of your frame with a single brush stroke, but you will 
have to scroll to see the paint.
7. To reset the Preferences to their original settings, click the Presets button.
All fields will return to their default settings.



Closing your Document 
To close your document, select the Close command from the File menu, or click the close box in the upper right-
hand corner of the document window. If the document has not been previously saved, or was changed since the 
last time it was saved, MediaPaint asks if you want to save your document before the window is closed. Because 
only one MediaPaint document can be opened for editing at a time, you must close the current document before 
opening another MediaPaint document. 



Exit
Choose Exit from the File menu when you are ready to quit MediaPaint. Before exiting, MediaPaint asks if you 
want to save changes to your document if any changes were made since the last Save.



Chapter 3
The Palettes

Introduction
MediaPaint’s extensive set of palettes makes it easy to paint on video to create your own special effects. This 
chapter will introduce you to the MediaPaint palettes and explain how to use them to achieve the best results.
Many of the MediaPaint tools will be familiar if you have used standard draw or paint programs. However, some 
of the tools will be completely new to you.
You should note that many of the tools described in the various sections of this chapter have modifiers that alter 
the tool’s normal behavior. These modifiers give you added power and flexibility with the effects you are trying 
to create. The applicable modifiers will be listed with each tool’s description. A full explanation of each modifier 
is given in the Tool Modifiers section of this chapter.
MediaPaint’s palettes provide easy access to tools, colors, patterns, brushes, and other controls and features 
built into the software. Some of the palettes also provide means of creating your own library of custom palettes.
MediaPaint’s seven basic palettes are:

· Tool Palette. This palette contains basic tools and tool modifiers (used to change the behavior of the tools). 
The tool palette also displays the Strata and third-party plug-in tools available for use.

· Sample Palette. This palette displays the currently selected brush, fill color and pattern, line color and pattern,
and film color and pattern.

· Color Palette. The active color palette is displayed when the Show Colors option is selected from the View 
menu. You can have as many color palettes loaded as your machine’s memory will permit, but only the active 
palette will be displayed.

· Pattern Palette. The different patterns available in the active pattern palette are displayed here. As with the 
color palette, you can have numerous pattern palettes open, but only the active palette will be displayed.

· Brush Palette. This palette displays the brushes available in the active brush palette. Again, you can load 
several brush palettes during a session and switch between them to select the brush you want, but only the 
active palette will be displayed when the Show Brushes option is selected.

· Info Palette. This palette displays information regarding pointer position, distance traveled, and angle of 
movement.

· Movie Controls Palette. The controls on this palette operate similar to the controls on a VCR. The controls 
include Play/Pause, Record, Frame advance/reverse, Rewind and Fast Forward.



Customizing Your Screen
Four palettes will open by default with the document window the first time you launch MediaPaint. These four 
palettes, the Tool palette, the Sample palette, the Color palette, and the Movie Controls palette are the primary 
palettes you will use in your project.

· The document window shows the active frame of the work area. While this window is active you can apply 
paint and perform all editing functions to paint on the Paint layer. The document window is always active 
unless the Filmstrip or Stencil window is active. You can toggle the active window by clicking on the desired 
window.

· The Tool palette displays the tools available for painting. The top section of the palette consists of the painting
and drawing tools and the selection tools. The center section of the palette contains the Tool modifiers, which 
allow you to change the behavior of certain tools. The bottom section presents a scrolling palette of custom 
plug-in tools you can use for more specialized painting functions.

· The Sample palette shows the current paint options at a glance. The palette includes graphic displays of the 
current fill, line, and film colors and patterns. The pop-up menus, which can be torn away from their parent 
palettes, let you change paint colors and patterns. The pop-up menu on the right under the small brush icon 
lets you change the current brush.

· The Movie Controls palette lets you navigate through the frames of your work area. From this palette you can 
page back and forth between frames, control how fast the movie plays while you paint, set the Auto-Copy 
paint mode, play a movie for review, and toggle the LightBox on and off. MediaPaint will automatically keep 
the Movie, Paint and Stencil layers in synchronous time as you move from frame to frame.

· The Colors palette presents the currently available colors. The pop-up menu lets you choose between all 
loaded colors. You should note that all paints, including the standard colors and stencils, are treated 
essentially the same in MediaPaint. Each of these types of paint can be applied and edited on the Paint layer 
with various brushes and tools.

All the palettes in MediaPaint are free floating, which allows you to move them wherever you want on your 
screen by clicking in the title bar and dragging the palette to a new position. You can instruct the application to 
remember the palette locations and open them in the same place each time. You can also decide which palettes 
you want displayed whenever you open a document.
To toggle the palette displays on or off use the Show/Hide commands in the View menu, or use the Control-key 
shortcuts listed to the right of each command. When you have the screen arranged the way you want it to 
appear each time you launch MediaPaint, select Remember Positions in the Preferences dialog and Exit. 
You can toggle all open palettes on or off with the Show/Hide Palette Windows command from the View menu 
(Ctrl + 0). 



The Tool Palette
The Tool palette displays the basic tools and tool modifiers (used to modify the behavior of the tools) available in 
MediaPaint. The palette also displays available MediaPaint and third-party plug-in tools. You can Show/Hide the 
palette with the Ctrl + 1 keyboard shortcut.
Hot key shortcuts for the basic tools in the Tool palette are available only when the Use Hot Key option is turned 
on in the Preferences dialog box.

See Also:
Basic Tools Tool 

Modifiers    
Plug-In Tools Particle tools   

Marquee Tool Shrink mode Airbrush Tool BabyBoom 
Lasso tool Layer mode Blur Tool PixieDust 
Grabber tool Composite mode Burn Tool SpinOut 
Zoom tool Anti-alias mode Diffuse Tool Squiggle 
Color Pickup 
tool 

Corner/Center 
mode 

Distort Tool 

Eraser tool Line Weight Dodge Tool 
Text tool Fade In Tool 
Pencil tool Fade Out Tool 
Brush tool Fine Brush Tool 
Fill Bucket tool Invert Tool 
Line tool Magic Wand Tool 
Rectangle tool Rubber Stamp Tool 
Oval tool ShapePainter Tool 
Polygon tool Sharpen Tool 

Smear Tool 
Smudge Tool 



Marquee tool
Hot key: S (S for Selection)
The Marquee is a selection tool used to select and move paint. To use the Marquee tool, simply select it from the 
Tool palette and click-and-drag a box around the paint you want selected. A “marching ants” border will appear 
around your selection when you release the mouse button. Once the paint has been selected it can be moved 
anywhere on the Paint layer by positioning the cursor on the selection and using the click-and-drag method to 
reposition the paint. To leave a copy of the selection behind as you click-and-drag it, hold down the Alt key while 
moving your selection. Double-clicking on the marquee tool will select all of the paint on the current frame’s 
paint layer (this function is identical to choosing Select All from the Edit menu).
It is important to remember that selected paint is no longer part of the Paint layer. Selected paint can be copied, 
pasted to a single frame, or pasted to a range of frames. However, selected paint is not committed to any frame 
and will not show up on the Filmstrip until it is deselected.
The behavior of the marquee tool can be modified through the pop-up menus in the center of the Tool palette. 
See the section on tool modifiers later in this chapter.
Modifiers available for the marquee tool:

· Shrink mode
· Layer mode
· Composite mode
· Corner/Center mode



Lasso tool
Hot key: L
The lasso is also a selection tool. While the Marquee tool selects paint inside its rectangular border, the lasso 
allows selection of areas within a free-form border. Double-clicking on the lasso will select all of the paint on the 
Paint layer.
The behavior of the Lasso tool can be modified through pop-up menus in the center of the Tool palette.
Modifiers available for the Lasso tool:

· Shrink mode
· Layer mode
· Composite mode

Special selection tool features
Both the Marquee and Lasso tools have special features that allow you to use them more easily. The Hide/Show 
Selection Border command in the Edit menu lets you turn the marching ants selection border on or off. This is 
especially useful when moving a selection into exact position on the Paint layer because you can turn the border 
off to get a better view of the selection.
Another special feature of both selection tools is the ability to move a selected object without having the pointer 
directly over the object. This is helpful when working with very small selections that can be difficult to grab or 
see when obscured by the cursor. To use this feature on a selected object simply position your cursor anywhere 
in the document window where it will not obscure your view and depress the Ctrl key while dragging the selected
object. If your cursor was in the top, right corner of the document window and the selected object was in the 
bottom half of the window, you could move the object using this method.



Grabber tool
Hot key: G
The Grabber tool allows movement of the document similar to the scroll bars. This tool only pertains to projects 
in which the document window is smaller than the document size. To use the Grabber tool, select the hand icon 
from the Tool palette and position the cursor in the document window. Use the click-and-drag method to move 
the document horizontally and vertically until it is correctly positioned.



Zoom tool
Hot key: Z
The Zoom tool is used to magnify your document view. To use the Zoom tool, select the magnifying glass icon 
and click the mouse on the area you wish to enlarge. Your document will be displayed at the next larger 
magnification level each time you click in the document window.
To demagnify, hold down the ALT key and click on the document with the zoom tool. Each time you click with the 
ALT key held down, your document will appear at the next smaller magnification size.
Double-clicking on the zoom tool will toggle between Zoom In and Zoom Out. You can also choose Zoom In and 
Zoom Out from the View menu. Choose Actual Size to return to a 100% view of your document.



Color Pickup tool
Hot key: tab key
Use the Color Pickup tool, also known as the Eyedropper tool, when you want to match an existing color. To pick 
up a color from anywhere in the document window select the Color Pickup tool and click the eyedropper on the 
color you want to match. The Color Pickup tool grabs color from the final image, which means it can pull any 
color from any layer of your document. This sets the fill color. Holding the Ctrl key while clicking on a color will 
set the line color. Holding the ALT key while clicking with the Color Pickup tool sets the film color.



Eraser tool
Hot key: E
The purpose of the Eraser tool should be fairly straightforward. To use the tool, click-and-drag over the paint you 
want to remove from your document. Double clicking on the eraser will remove all paint from the active frame of
the document. If you mistakenly erase part or all of the paint on the active frame, select Undo from the Edit 
menu.
The Undo command is available for most operations. However, you must choose Undo immediately after the 
incorrect action. The Undo command will only undo the last action you performed.



Text tool
Hot key: T
The Text tool allows you to add text to your document. To use the Text tool, click in the document window with 
the tool selected and type. You can select the font, font size, and style for your text from the appropriate menu 
before you begin to type or after the text has been written by dragging the cursor over the text to select it and 
making your changes. You can resize the text box by click-and-dragging the corner handles with the Text tool still
selected. However, once you commit the text to the Paint layer it becomes a paint object and can no longer be 
edited with the Text tool. The current fill color displayed in the Sample palette will be used as the text color. 
Modifiers available for the Text tool:

· Anti-alias mode
· Corner/Center mode



Pencil tool
Hot key: . (period)
The Pencil tool allows you paint a single pixel at a time. The pencil will paint each pixel in the current fill color. 
However, if you click on an area that is already painted with the current fill color the pencil will erase instead. If 
the film pattern is set to None, clicking on a pixel with the pencil will reveal the movie layer image. No paint will 
be laid down with the pencil tool if the Fill color is set to None.



Brush tool
Hot key: B
This tool applies paint with the currently selected brush. To use the tool, simply click-and-drag in the document 
window with the tool selected. You can change the color of the paint by clicking on a new color in the Color 
palette or by click-and-dragging to a new color in the Sample palette’s Fill color pop-up palette.
The brush is a freehand tool that paints the currently selected color or the actual color of the brush as you move 
it across the Paint layer (see the discussion of the Brush palette for information on how to paint as is or with the 
selected color). You can change the style of your brush in the Brush palette. You can open the Brush palette by 
double-clicking on the brush tool, choosing Show Brushes from the View menu, or using the (Ctrl + 5) keystroke 
shortcut. You can also tear the Brush palette from the Sample palette by clicking-and-dragging on the Sample 
palette’s brush preview box. You can load as many Brush palettes as memory permits through the Open palette 
command in the Brush palette, but only one palette can be active at a time.



Fill Bucket tool
Hot key: F
This tool fills adjacent pixels sharing the same color with the currently selected fill color. You do not have to 
select the paint you want to change with the Fill Bucket. Rather, simply choose the new fill color and click the 
bucket on the old paint you want replaced. Clicking in an area with no paint will fill all adjacent areas of the Paint 
layer that have no paint with the new color, leaving paint that was laid down prior to the operation unchanged. 
You can change the tolerance settings of the Fill Bucket tool to control anti-aliasing and determine how the paint 
will leak to other colors.
Setting the tolerance
1. Choose Set Tolerance from the Layout menu, or doubleclick on the Fill Bucket tool.
The Set Tolerance dialog box will appear. 
2. Enter a value from 0 to 255.
This value will determine how the fill paint will leak to adjacent colors. A value of zero indicates colors must 
match exactly. A larger value, such as 35, means colors are considered equal if their values are within plus or 
minus 35 units of the fill color as determined in the RGB color space. Setting the tolerance to 255 will paint the 
fill color to all pixels in the frame, leaking the new paint over any existing paint.
 3. The Fill Bucket tool will mimic differences in shading when the Antialias checkbox is turned on.
Anti-aliasing with the Fill Bucket tool ensures shading differences in like colors are maintained. An example of 
this would be sampling an image which is partly shadowed. The area falling under the shadow is the same color 
as that portion in the light, but it appears darker because of the shadow. Using anti-aliasing maintains the 
shadow’s shading on the image while applying the new fill color, which will create shading variations in the new 
color that match the variations in the original color. With anti-aliasing turned off, the new color will fill the area 
without the shadowed variations to produce a flat, solid color.
 4. Click OK to make the changes effective.
Modifiers available for the Fill Bucket tool:

· Layer mode



Line tool
Hot key: /
Use this tool to draw straight lines. The line will be drawn with the current line color and pattern. You can choose 
a width from the Line Weight pop-up menu in the center portion of the Tool palette. If you need a custom line 
weight, choose Other and enter the desired width and height for lines and borders in the dialog box. 
Modifiers available for the Line tool:

· Anti-alias mode
· Corner/Center mode
· Line Weight 



Rectangle tool
Hot key: R
This tool draws a rectangle filled with the current fill color and pattern. The rectangle will be framed using the 
current line color and pattern. Holding the Shift key while drawing a rectangle will constrain the sides to create a 
square.
Modifiers available for the Rectangle tool:

· Corner/Center mode
· Line Weight 



Round Rectangle tool 
Hot key: N
The Round Rectangle tool works the same as the standard Rectangle tool except that the corners are rounded. 
You can change the roundness of the corners through the Set Round Corners command in the Layout menu. You 
can also access the roundness dialog by double-clicking on the round rectangle button.
Changing the roundness of corners
1. Choose the Set Round Corners command from the Layout menu or doubleclick on the Round Rectangle 
tool.
The Set Round Corners dialog box will appear.
2. Select a unit of measurement.
You can use the buttons to select Pixels, Inches, or Centimeters as the unit of measure.
3. Select a size for the radius.
Set the size of the radius around which the corner will be rounded by selecting one of the preset measurement 
buttons or enter custom numbers in the “Other” fields. The larger the radius, the rounder the corners of your 
rectangle will be.
 4. Click OK.
The settings will remain at the new settings each time you use the Round Rectangle tool until you change them 
again with the Set Round Corners options.
Modifiers available for the Round Rectangle tool:

· Anti-alias mode
· Corner/Center mode
· Line Weight 



Oval tool
Hot key: O
The Oval tool works the same as the rectangle tools except that it draws a circular shape. Holding the Shift key 
down while drawing will create a perfect circle.
You can determine the origin point from which the oval will be drawn with the Corner/Center mode modifier tool.
Modifiers available for the Rectangle tool:

· Anti-alias mode
· Corner/Center mode
· Line Weight 



Polygon tool
Hot key: P
To create free-form polygons, use the Polygon tool. Polygons are filled in the center with the current fill color and 
pattern and are framed using the current line color and pattern. To draw a free-form polygon, single-click a start 
point. A floating line will automatically form between the cursor and the start point as you move your cursor 
across the document window. Anchor the second point by single-clicking where you want the next corner of the 
polygon. Follow the same procedure to anchor the third point (a polygon must have a minimum of three points). 
To enter the last point of the polygon and complete the drawing, double-click where you want the final point.
Modifiers available for the Polygon tool:

· Anti-alias mode
· Line Weight 



The Tool Modifiers
The controls in the center section of the Tools palette modify the behavior of certain tools. Each modifier button 
contains a pop-up menu with the choices available for that mode.
You should note the modifiers are in their own section of the Tools palette and appear active at all times even 
though the modifier may not pertain to the tool you have selected. The modifiers are set up that way to provide 
the best support for standard tools and various Strata and third-party Plug-in tools.

See Also:
Shrink mode 
Layer mode 
Composite 
mode 
Anti-alias 
mode 
Corner/Center 
mode 
Line Weight 



Shrink mode
The Shrink mode modifier pertains to the Marquee and Lasso selection tools. Changing the modifier also changes
both selection tool icons to reflect the shrink mode.

· No shrink (none) leaves the selection area, recognized by a marching ants border, exactly as you draw it.
· Shrink wraps the selection border tightly around the paint within the selected area. This mode is especially 

important when using the Slip None function to select paint that is different than the film color. Please refer to
the section of this manual discussing the Slip None function for more information.

· Shrink to rectangle wraps the marquee to the smallest rectangle capable of holding the paint inside the 
selection area.

· Shrink with holes works like the shrink mode except that any areas within the selection that do not have paint
are excluded. For example, if you draw a selection marquee around the letter “A” while the Shrink with holes 
modifier is turned on, the selection border will wrap tightly around the outside of the letter and around the 
inside “hole” of the letter “A.”



Layer mode
This mode affects the selection tools and the Fill Bucket tool. You can choose from three layer settings: Paint, 
Movie, or Paint and Movie.

· Paint allows you to work on the Paint layer only.
· Movie allows you to:
· Select an area of the Movie layer with a selection tool and copy that image to the Paint layer without affecting

paint already on the Paint layer. When you have selected an area, you can leave it directly over the movie 
image or drag it with the cursor as you would any other selection to the desired position. If the selection 
includes an area where paint has been applied to the Paint layer, the old paint will be covered by the new 
image, but will remain undisturbed and will not be copied into the selection. Moving the new image prior to 
deselecting it will reveal the hidden paint. Once the image from the Movie layer is on the Paint layer you can 
edit it as you would any other paint.

· Use the Fill Bucket tool to compare colors from the Movie layer image when performing the fill function. The 
Fill Bucket functions exactly as it would when performing a fill on images in the Paint layer, but tolerance 
settings are applied to the Movie layer only. Any paint already on the Paint layer is left untouched by the Fill 
Bucket function while in this mode. You should note that, while the function samples and places paint based 
on the image in the Movie layer, the fill paint is flowed onto the Paint layer where it can be edited.

· Paint and Movie allows you to:
· Select objects from the Paint layer and images copied from the Movie layer. Once selected, you can move the 

copied image from the Movie layer, complete with any objects on the Paint layer that are included in the 
selection area, to a new position in the document window. You will note the paint from the Paint layer is not 
copied in this scenario but is part of the selection. When you move the selection, the paint inside the selection
marquee goes with it. The original image from the Movie layer will, of course, still be in place (remember, the 
Movie layer is read only and cannot be edited).

· Match colors in both the Movie and Paint layers when using the Fill Bucket tool. The fill paint is then applied to
the Paint layer according to the tolerance settings.



Composite mode
This mode affects how selections are applied to the Paint layer. The two Composite modes are add and replace.

· The add composite mode allows selected paint to accumulate on top of existing paint.
· The replace composite mode causes selected paint to replace existing paint. 



Anti-alias mode
To get the smoothest edges on the various shape tools (line, rectangle, rounded rectangle, oval, and polygon 
tools), choose a smoother setting from the Anti-aliasing pop-up menu. The apparent smoothness of the lines is 
accomplished by smoothing the level of alpha along the line’s edge to create a soft transition between pixels. 
You should note that turning the anti-aliasing on full will use more memory while the image is being rendered.



Corner/Center mode
To start drawing from the cursor’s beginning position to its ending position when using shape tools you should 
use the corner-to-corner mode.
Select the center-to-corner mode to set the cursor’s starting position as the center of the shape you are going to 
draw. As you drag the cursor away from that point the shape will be enlarged proportionally from the center 
point. This command also affects the Line and Marquee tools.



Line Weight
Choose a line width for the shape tools and the Line tool from the Line weight pop-up menu. If you need a 
custom line weight, choose Other from the Line weight pop-up menu and enter the line weight you want.
The Other Line Weight dialog box allows you to enter a width and height for lines and borders.



Plug-In Tools
The bottom section of the Tools palette displays specialized plug-in tools. These tools allow you to add 
customized details and special effects to your project and often provide more flexibility and control than the 
basic tools. Most plug-in tools can be customized by choosing the Set Tool Options command from the Layout 
menu while the tool is active or double-clicking on the tool icon and changing the settings in the corresponding 
dialog. 

See Also
Airbrush Tool 
Blur Tool 
Burn Tool 
Diffuse Tool 
Distort Tool 
Dodge Tool 
Fade In Tool 
Fade Out Tool 
Fine Brush 
Tool 
Invert Tool 
Magic Wand 
Tool 
Rubber 
Stamp Tool 
ShapePainter 
Tool 
Sharpen Tool 
Smear Tool 
Smudge Tool 



Airbrush Tool

This tool paints using a round stream of paint that can be customized using the settings in the Airbrush dialog. 
By default, the airbrush applies a very fine stream of paint with feathered edges. You can change the way the 
airbrush applies paint through its tool options dialog. You can use the slider bars or the up/down arrows to 
change any of the values, or you may enter the numeric values directly.

The Airbrush tool settings
Access the Airbrush settings dialog through the Set Tool Options command in the Layout menu (make sure you 
have the airbrush selected first), or by double-clicking on the Airbrush tool. 
Size

Enter the diameter (in pixels) of the airbrush footprint. The preview will reflect any changes. 

Pressure
The Pressure setting controls the transparency of the paint. The higher the pressure, the higher the alpha and 
the more opaque the paint. Lowering the pressure reduces the amount of alpha and makes the paint more 
transparent. This slider control is designed to give the mouse capabilities similar to those of a pressure sensitive 
tablet. The pressure setting is entered as a percentage from 1 to 100. 
Flow
Flow sets the speed at which the airbrush repeats paint application. This is most evident when keeping the 
airbrush in a single position and holding the primary mouse button down. A high Flow setting will place paint on 
top of paint very quickly while a low Flow setting will repeat laying down paint at slower intervals.
Step
Step determines how far each footprint overlaps the next as the airbrush is dragged across the document 
window. The value entered here represents a percentage of the size of the airbrush footprint (in pixels). For 
example, if the Size is set at 30 pixels and the Step is set to 50 percent, the airbrush will lay down a new 
footprint every 15 pixels, overlapping half the area of the last footprint. If Step is set to 100 percent, the redraw 
occurs every 30 pixels, which means there is no overlapping of the airbrush footprint.
Softness
The Softness setting refers to the paint’s density as you move away from the center of the airbrush footprint. 
This could be likened to the amount of over-spray from a real airbrush. Increasing the Softness disburses the 
paint more widely toward the outer rim to create a gently diminishing amount of over-spray. Decreasing the 
Softness setting lays down a more dense over-spray pattern which, at the lowest settings, makes the airbrush 
footprint appear to be a solid circle of paint.
Edge Opacity
The Edge Opacity controls the transparency of the paint as it approaches the outer circumference of the airbrush
footprint. To determine the opacity across the footprint, the center point is considered fully opaque. If the Edge 
Opacity is set to 50 percent, the outer rim of pixels in a single footprint would be half as opaque as the center 
pixel, or twice as transparent.
Preset
The Preset button will revert all fields in the dialog to their default settings.



Blur Tool

The Blur tool averages differences in colors and smooths those differences to create a blending between 
contrasting colors. This has the effect of blurring the area you click-and-drag over. The Blur tool uses the 
currently selected brush and only affects the area you drag the tool over. The effects of the Blur tool are not 
cumulative, which means you must either click repeatedly on a single area to continue the blurring effect on 
already blurred pixels or click-and-drag the Blur tool repeatedly over the same area to increase the blur.

The Blur tool settings
Access the Blur tool dialog box through the Set Tool Options command in the Layout menu while the tool is 
selected or by double-clicking on the Blur tool button. You can use the slider bars or the up/down arrows to 
change the values or enter the numeric values directly. 
Pressure
The Pressure setting determines the percentage of alpha used. The higher the pressure, the higher the alpha, 
and the more opaque the paint. Lowering the pressure reduces the amount of alpha and makes the paint more 
transparent. The Pressure setting allows the mouse to emulate a pressure-sensitive tablet. 
Step
Step determines how far a brush’s footprint overlaps its last as the brush is dragged across the document 
window. The value entered here represents a percentage of the brush footprint (in pixels). Settings less than 100 
percent will result in increasingly overlapping occurrences of paint. You should note that lowering the Step 
setting will create a smoother flowing line, but it will also take longer to draw the line due to the increased 
computations needed to perform the operation.
Preset
The Preset button will revert all fields in the dialog to their default settings.



Burn Tool

In a photographer’s darkroom, burning an image is a technique for exposing a section of photographic paper to 
more light to darken an area that is not well defined or is washed out on the negative. The more light the paper 
is exposed to the darker the image will appear. MediaPaint’s Burn tool works much the same in that pixels the 
brush passes over are enhanced to appear darker. 
The Burn tool allows you to select the range of luminosity (shadows, midtones, or highlights) you want to 
enhance prior to the operation, through the tool’s option dialog. You can also affect the amount of exposure 
(simulated light) you subject the image to during a single pass of the tool through the settings dialog.

The Burn tool settings
Access the Burn tool dialog box through the Set Tool Options command in the Layout menu while the tool is 
selected or by double-clicking on the Burn tool button. You can use the slider bars or the up/down arrows to 
change the values or enter numeric values directly. Buttons are also provided for selecting the range of 
luminosity you want to affect during a specific pass of the tool. You should note that only one range can be 
selected at a time.
Shadows
Selecting the Shadows button will cause the Burn tool to focus on darker colors and shades in the area the tool 
passes over. Those pixels containing the darkest third of the scale are darkened proportionally with their 
respective values. Colors falling in the midrange of the light scale are only affected slightly. Light colors on the 
high end of the scale are affected even less, often not showing any visible signs of the burn operation unless 
numerous passes of the tool have occurred.
Midtones
Turning on the Midtone button forces the Burn tool to concentrate its efforts on colors falling into the mid range 
of the light scale. Obviously, those colors falling into the upper and lower ranges are only affected slightly during
the operation. Because all pixels will be affected with the Burn tool on this setting, you should use caution when 
making multiple passes over an image.
Highlights
Setting the Burn tool to focus on the highlights of the image affects primarily the lightest colors in the area the 
tool passes over. Midtones are affected slightly during the process and the darkest colors receive only minimal 
enhancement.
You should exercise caution using this setting. Because the tool will be focused on darkening the lightest pixels, 
darker colors, even though they are only slightly affected, could become indiscernible after only a single pass of 
the tool.
Exposure
The Exposure setting determines the intensity of the Burn tool’s enhancement algorithm. Increasing the 
exposure setting will cause the pixels to be darkened very quickly, but may also cause the overlapping affect 
between light ranges to increase. Setting the exposure too high could result in the creation of a black spot where
the Burn tool is used.
Step
Step determines how far a brush’s footprint overlaps its last as the brush is dragged across the document 
window. The value entered here represents a percentage of the brush footprint (in pixels). Settings less than 100 
percent will result in increasingly overlapping occurrences of paint.
Preset
The Preset button will revert all fields in the dialog to their default settings.



Diffuse Tool

Use this tool to displace paint as you drag over an area. This causes the paint to appear fuzzy or randomized. 
The Diffuse tool uses the currently selected brush.

The Diffuse tool settings
Access the Diffuse tool dialog box through the Set Tool Options command in the Layout menu while the tool is 
selected or by double-clicking on the Diffuse tool button. You can use the slider bars or the up/down arrows to 
change the values or enter numeric values directly.
Spread
Spread determines how far a single pixel of paint can be displaced. The Diffuse tool randomly moves pixels of 
paint up to the maximum set in the Spread field. The range of displacement can be set from 1-16 pixels. You 
should note the diffusion cannot extend beyond the boundaries of the brush you are using. For example, if you 
use a six-pixel-wide brush and set the Spread field to 10, the farthest the pixel can be displaced from its original 
position will be six pixels.
Step
Step determines how far a brush’s footprint overlaps its last as the brush is dragged across the document 
window. The value entered here represents a percentage of the brush footprint (in pixels). Settings less than 100 
percent will result in increasingly overlapping occurrences of paint.
Preset
The Preset button will revert all fields in the dialog to their default settings.



Distort Tool
The Distort tool allows you to “push” portions of paint around the document window as you drag a brush across 
the document window. When this tool is used, paint is actually displaced from its original position to another 
point along the tool’s path as you drag it over the paint. How far the paint is pushed out of place and the amount
of feathering along the edges is determined by the Distort tool dialog settings and the type of brush chosen prior
to selecting the Distort tool. This tool will affect any paint you have placed on the Paint layer using a brush or 
tool, including Stencil paint or copied images from the Movie layer. 

The Distort tool settings
Access the Distort tool dialog box through the Set Tool Options command in the Layout menu while the tool is 
selected or by double-clicking on the Distort tool button. You can use the slider bars or the up/down arrows to 
change the values or enter the numeric values directly through the keyboard when a field is selected. 
Distortion
The percentage of distortion determines how far the paint will be pushed out of place based on the size of the 
brush being used. For example, if the Distortion field is set to 100 percent and you are using a brush measuring 
10 pixels across, the farthest any pixel of paint can be moved is 10 pixels in a single Step. However, a pixel may 
actually be moved significantly farther from its original position when the Step field is set low and the Distortion 
field is set high. This is because many of the pixels that are moved in the first Step are picked up and moved 
again in the second Step, and so on.
The previous illustration demonstrates the effects of various settings in the Distort dialog. Notice how the bottom
example shows the paint pushed off the document window. This is because the Distortion and Step field settings 
allowed most of the paint that was picked up in the first sampling to be moved within the sampling range of each
consecutive Step. The result is an exaggerated displacement of the first color that was sampled.
Step
Step determines how far a brush’s footprint overlaps its last as the brush is dragged across the document 
window. The value entered here represents a percentage of the brush footprint (in pixels). Settings less than 100 
percent will result in an increase in overlapping occurrences of paint.
Presets
The Preset button will revert all fields in the dialog box to their default settings.



Dodge Tool

The Dodge tool allows you to soften detail by “dodging” out an area of the image in the Paint layer. This tool 
works much like the photographic process of preventing light from striking photographic paper by blocking all or 
part of the light during processing. This technique is generally used when part of the film is underexposed, which
creates very dark areas in the negative.

The Dodge tool settings
Access the Dodge tool dialog box through the Set Tool Options command in the Layout menu while the tool is 
selected or by double-clicking on the Dodge tool button. You can use the slider bars or the up/down arrows to 
change the values or enter numeric values directly. Buttons are also provided for selecting the range of 
luminosity you want to affect during a specific pass of the tool. You should note that only one range can be 
selected at a time.
Shadows
When Shadows is selected, the Dodge tool will lighten the darkest pixels in the area the tool passes over. 
Midtone colors will be lightened slightly and highlight colors even less.
Midtones
The Dodge tool will focus on lightening the colors that fall into the mid range when this option is selected. 
Shadows and highlights will each be affected slightly during the operation.
Highlights
You should be cautious when using the Dodge tool on highlights to avoid creating white spots on your image. 
Midtones will also be affected slightly with this setting. Shadows may not begin to show the Dodge tool’s effects 
for several passes.
Exposure
The Exposure setting determines the intensity of the enhancement algorithm. Increasing the exposure setting 
will cause the paint to be lighten very quickly, but may also cause the overlapping affect between light ranges to
increase. Setting the exposure too high could result in the creation of white spots or washed out areas where the
tool is used.
Step
Step determines how far a brush’s footprint overlaps its last as the brush is dragged across the document 
window. The value entered here represents a percentage of the brush footprint (in pixels). Settings less than 100 
percent will result in increasingly overlapping occurrences of paint.
Preset
The Preset button will revert all fields in the dialog to their default settings.



Fade In Tool

This tool increases the opacity of the paint you drag the tool over by raising the alpha level of that paint. If you 
click-and-drag the tool over the same area repeatedly, the opacity of the paint will increase with each 
consecutive pass. However, the effect is not additive if you hold the mouse stationary. Therefore, you must click 
the mouse repeatedly if you are only trying to affect a specific region. The Fade In tool uses the currently 
selected brush. 

The Fade In tool settings
Access the Fade In tool dialog box through the Set Tool Options command in the Layout menu while the tool is 
selected, or by double-clicking on the Fade In tool button. You can use the slider bars or the up/down arrows to 
change the values or enter numeric values directly.
Pressure
The Pressure setting determines the percentage of alpha used. The higher the pressure, the higher the alpha and
the more opaque the paint. Lowering the pressure reduces the amount of alpha and makes the paint more 
transparent. The Pressure setting allows the mouse to emulate a pressure sensitive tablet. 
Step
Step determines how far a brush’s footprint overlaps its last as the brush is dragged across the document 
window. The value entered here represents a percentage of the brush footprint (in pixels). Settings less than 100 
percent will result in increasingly overlapping occurrences of paint.
Preset
The Preset button will revert all fields in the dialog to their default settings.



Fade Out Tool

The Fade Out tool has the opposite effect of the Fade In tool in that it reduces the alpha level of the paint you 
drag the tool over, thereby increasing the transparency of that paint. If you click-and-drag the tool over the same
area repeatedly, the transparency of the paint will increase with each consecutive pass. However, like the Fade 
In tool, the effect is not additive when the mouse is held stationary. You must click the mouse repeatedly if you 
are trying to affect a specific region. The Fade Out tool uses the currently selected brush.

The Fade Out tool settings
Access the Fade Out tool dialog box through the Set Tool Options command in the Layout menu while the tool is 
selected, or by double-clicking on the Fade Out tool button. You can use the slider bars or the up/down arrows to 
change the values or enter numeric values directly.
Pressure
The Pressure setting determines the percentage of alpha used in the affected paint object. The higher the 
pressure, the higher the alpha will be set and the more opaque the paint. Lowering the pressure reduces the 
amount of alpha and makes the paint more transparent. The Pressure setting allows the mouse to emulate a 
pressure sensitive tablet. 
Step
Step determines how far a brush’s footprint overlaps its last as the brush is dragged across the document 
window. The value entered here represents a percentage of the brush footprint (in pixels). Settings less than 100 
percent will result in increasingly overlapping occurrences of paint.
Preset
The Preset button will revert all fields in the dialog to their default settings.



Fine Brush Tool
This tool allows you to fine tune the settings of your currently selected brush. The Fine Brush tool does not alter 
the size or shape of the brush you are using. Rather, the tool allows you to make the paint more transparent or 
flow from the brush faster. This tool works with any brush from a loaded Brush palette. The settings used for the 
Fine Brush tool will remain in effect until you change them, even if you exit the program.

The Fine Brush tool settings
Access the Fine Brush tool dialog box through the Set Tool Options command in the Layout menu while the tool is
selected or by double-clicking on the tool button. You can use the slider bars or the up/down arrows to change 
the values or enter numeric values directly.
Pressure
The Pressure setting controls the amount of alpha in the paint. The higher the pressure, the higher the alpha and
the more opaque the paint. Lowering the pressure reduces the amount of alpha and makes the paint more 
transparent. This slider control is designed to give the mouse capabilities similar to those of a pressure-sensitive 
tablet. The pressure settings are entered as percentages from 1 to 100. 
Flow
Flow sets the speed at which the brush repeats paint application. This is most evident when keeping the brush in
a single position and holding the primary mouse button down. A high Flow setting will place paint on top of paint 
very quickly while a low Flow setting will repeat laying down paint at slower intervals.
Step
Step determines how far a brush’s footprint overlaps its last as the brush is dragged across the document 
window. The value entered here represents a percentage of the brush footprint (in pixels). Settings less than 100 
percent will result in increasingly overlapping occurrences of paint. You should note that lowering the Step 
setting will create a more smoothly flowing line, but it will also take longer to draw the line due to the increased 
computations needed to perform the operation.
Preset
The Preset button will revert all fields in the dialog to their default settings.



Invert Tool

The Invert tool changes the color of the paint the tool is dragged over to the opposite color on the color wheel. 
For example, if the original paint color is blue, any area of that paint the Invert tool is dragged over will change 
to yellow.
If you use a soft-edged brush with the Invert tool, those areas along the outside edges of the brush will become a
composite of the original color and the opposite color. Continued use of the Invert tool over soft edges will 
eventually produce a graduating grayscale. Completely opaque paint with hard-defined edges will merely shift 
from one color to the other with continuous use of the Invert tool. The Invert tool uses the currently selected 
brush. You can adjust the transparency (pressure), flow and step of the Invert tool through the Invert dialog box.

The Invert tool settings
Access the Invert tool dialog box through the Set Tool Options command in the Layout menu while the tool is 
selected or by double-clicking on the Invert tool button. You can use the slider bars or the up/down arrows to 
change the values or enter numeric values directly.
Pressure
The Pressure setting controls the amount of alpha in the paint. The higher the pressure, the higher the alpha and
the more opaque the paint. Lowering the pressure reduces the amount of alpha and makes the paint more 
transparent. 
Flow
Flow sets the speed at which the brush repeats paint application. A high Flow setting will place paint on top of 
paint very quickly while a low Flow setting will repeat laying down paint at slower intervals.
Step
Step determines how far a brush’s footprint overlaps its last as the brush is dragged across the document 
window. The value entered here represents a percentage of the brush footprint (in pixels). Settings less than 100 
percent will result in increasingly overlapping occurrences of paint.
Preset
The Preset button will revert all fields in the dialog to their default settings.



Magic Wand Tool

The Magic Wand tool creates a selection by sampling a specific color range you determine through the tool’s 
dialog settings. By adjusting the settings, you can sample contiguous colors that match exactly or expand the 
range to include similar colors. 

The Magic Wand tool settings
Access the Magic Wand tool dialog box through the Set Tool Options command in the Layout menu while the tool 
is selected or by double-clicking on the Magic Wand tool button. You can use the slider bars or the up/down 
arrows to change the values or enter the numeric values directly through the keyboard when a field is selected. 
Tolerance
The Tolerance field establishes how close to the sampled color a contiguous pixel must be to be included in the 
Magic Wand selection. The slider uses a percentage of the 0-255 RGB scale to determine the selection area. For 
example, if you set the Tolerance to 30 percent and select a pixel with a color designation of 100 on the red 
scale, contiguous pixels with color designations ranging from 23.5 to 176.5 on the red scale will be selected. This
represents a plus and minus 30 percent variation for a total selection range of 60 percent.
As the previous illustration demonstrates, the Tolerance slider establishes the maximum variation of color 
allowed on either side of the color scale.
Presets
The Preset button will revert all fields in the dialog to the default settings.



Rubber Stamp Tool

The Rubber Stamp tool samples the entire active window from a specific reference point and remembers where 
colors are located. You can then paint an offset duplicate of all or part of the active window with the currently 
selected brush. Colors can be sampled from the Paint layer, the Movie layer, or both by changing the Layer Mode
selection in the Tools palette.

Using the Rubber Stamp tool
1. Select the appropriate layer mode from the Tools palette.
If the image you want to duplicate with the Rubber Stamp tool is in the Movie layer, set the Layer Mode to Movie.
Setting the Layer Mode to the Paint layer will sample only those colors residing on that layer. If you want to 
duplicate all the colors in both layers of the active window, set the Layer Mode to the Paint and Movie layer 
mode. 
2. Establish the starting reference point.
This is done by simply selecting the Rubber Stamp tool and clicking with the Alt key on a point in the active 
window from which you want start sampling the image. If you plan to duplicate the image of a road sign, for 
example, you may want to Alt-click in the center of the sign to establish that as the reference point.
3. Paint the duplicate image in the document window.
Position the cursor where you want the duplicate image to appear. Click and drag the mouse to paint the image 
with the currently selected brush. You will notice a cross-hair cursor appears on the original reference point and 
moves simultaneously with the brush to provide you with a guide while you are painting. The brush will paint a 
duplicate of the original image in the new position starting from the exact point on the original color you 
designated as the reference point. 
The duplicate image will be placed 10 pixels to the right and 10 pixels down from the original image if you fail to 
hold the Alt key down when establishing the starting reference point.

The Rubber Stamp tool settings
Access the Rubber Stamp tool dialog box through the Set Tool Options command in the Layout menu while the 
tool is selected or by double-clicking on the Rubber Stamp tool button. You can use the slider bars or the 
up/down arrows to change the values or enter the numeric values directly through the keyboard when a field is 
selected. 
Pressure
The Pressure setting in the Rubber Stamp dialog determines the percentage of alpha used. The higher the 
pressure, the higher the alpha and the more opaque the paint. Lowering the pressure reduces the amount of 
alpha and makes the paint more transparent.
Step
Step determines how far a brush’s footprint overlaps its last as the brush is dragged across the document 
window. The value entered here represents a percentage of the brush footprint (in pixels). Settings less than 100 
percent will result in an increase in overlapping occurrences of paint.
Presets
The Preset button will revert all fields in the dialog to their default settings.



ShapePainter Tool

The ShapePainter tool will lay down one frame in a series of animated drawings each time you click the tool in 
the active window. The shapes are selected from the palette currently loaded for the tool and can be chosen at 
random or in the order they appear in the palette. You can also set the tool to paint the shapes with the colors 
they were created in (Paint As Is), or with the current fill color.
Any brush palette can be loaded for use by the ShapePainter, but only one palette may be loaded at a time. If 
you want to use shapes from another palette, you must load that palette from the ShapePainter dialog.
You can build your own palette of ShapePainter brushes simply by creating a new brush palette with the shapes 
you want to use. Once created and saved, you can load your custom palette into the ShapePainter and paint 
away. Please refer to the Brush Palette section of this chapter for information on creating brushes and brush 
palettes.

The ShapePainter settings
To access the ShapePainter tool’s options settings, double click on the tool’s button or select the Set Tool Options
command from the Layout menu with the tool selected. You can use the slider bars to set each field or use the 
up/down arrows. You can also enter exact values in the fields through the keyboard.
Pressure
The Pressure setting controls the amount of alpha in the paint. The higher the pressure, the higher the alpha and
the more opaque the paint. Lowering the pressure reduces the amount of alpha and makes the paint more 
transparent. 
Flow
Flow sets the speed at which the brush repeats paint application. A high Flow setting will place paint on top of 
paint very quickly while a low Flow setting will repeat laying down paint at slower intervals. If you set the Flow to
zero, only one shape will be painted on each frame while recording.
Step
Step determines how far a brush’s footprint overlaps its last as the brush is dragged across the document 
window. The value entered here represents a percentage of the brush footprint (in pixels). Settings less than 100 
percent will result in increasingly overlapping occurrences of paint.
However, it is possible to use several different sizes of brushes in one application with this tool. Therefore, the 
Step setting may not produce exactly the same footprint overlap for each brush occurrence along a single stroke.
Apply shapes in order
This button tells the tool to select shapes from the currently loaded palette in the order they appear in that 
palette.
Apply shapes randomly
As the name implies, this button selects shapes from the currently loaded palette at random.
Presets
The Presets button will revert all fields in the dialog to their default settings.
Load . . .
The Load button lets you choose different palettes for the tool to use during that session. You can load any brush 
palette for use with the ShapePainter tool, but you can only have one palette loaded at a time.
You can have a brush palette loaded in the ShapePainter and have the same palette open for use with the brush 
tool. A palette does NOT have to be currently open in the Brush palette’s Command Pop-up menu to be loaded 
by the ShapePainter tool. However, you must use the Paint As Is in the Brush Palette command pop-up menu to 
have the Shapes painted with the colors they were created with.



Sharpen Tool
The Sharpen tool increases the differences between the pixels of the paint you drag over. This is accomplished 
by enhancing each color pixel. You should note that as each pixel is sharpened, gradient colors are diminished. 
Multiple passes over an area with the Sharpen tool could eventually eliminate gradient scales. These gradients 
are what produce smooth transitions between colors and shades. The result can be sharp, sometimes jagged 
edges between different colored pixels. The sharpen tool uses the currently selected brush.

The Sharpen tool settings
Access the Sharpen tool dialog box through the Set Tool Options command in the Layout menu while the tool is 
selected or by double-clicking on the Sharpen tool button. You can use the slider bars or the up/down arrows to 
change the values or enter numeric values directly.
Pressure
The Pressure setting controls the amount of alpha in the paint. The higher the pressure, the higher the alpha and
the more opaque the paint. Lowering the pressure reduces the amount of alpha and makes the paint more 
transparent. 
Step
Step determines how far a brush’s footprint overlaps its last as the brush is dragged across the document 
window. The value entered here represents a percentage of the brush footprint (in pixels). Settings less than 100 
percent will result in increasingly overlapping occurrences of paint. 
Preset
The Preset button will revert all fields in the dialog to their default settings.



Smear Tool
The Smear tool simulates the effect of a water droplet on paint. When the metaphoric droplet is applied to the 
paint, the colors in the tool’s path run together. This is accomplished by sampling the paint at regular intervals, 
as determined by the Step setting, and mixing the sampled colors according to the percentages established in 
the Smear dialog’s Pressure field. 

The Smear tool settings
Access the Smear tool dialog box through the Set Tool Options command in the Layout menu while the tool is 
selected or by double-clicking on the Smear tool button. You can use the slider bars or the up/down arrows to 
change the values or enter the numeric values directly through the keyboard when a field is selected. 
Pressure
The amount of pressure applied determines how colors are mixed. For example, when the Pressure field is set to 
30 percent, paint is sampled from the area covered by the selected brush, mixed at a 30-70 percent ratio (the 
original color comprising 70 percent of the mix), then stamped back down on the Paint layer. Obviously, the 
sample must be taken from an area containing at least two colors or there will be no affect.
The previous illustration shows how the red and white colors are mixed when the Pressure field is set to 30 
percent. An exaggerated brush size was used to produce an enlarged sampling area. Notice how the red area of 
the sampling is now a composite color representing a mixture of 70 percent red and 30 percent white. The 
affected white areas are a composite of 70 percent white and 30 percent red. At a setting of 50 percent, the two 
sampled colors would have been mixed evenly.
Step
Step determines how far a brush’s footprint overlaps its last as the brush is dragged across the document 
window. The value entered here represents a percentage of the brush footprint (in pixels). Settings less than 100 
percent will result in an increase in overlapping occurrences of paint.
Presets
The Preset button will revert all fields in the dialog to their default settings.



Smudge Tool
The Smudge tool produces an effect similar to dragging your finger across a canvas through wet oil-based paint. 
As your finger moves through one color into another, the paint from the previous color is dragged into the next, 
creating a smooth smudge across the affected area.

The Smudge tool settings
Access the Smudge tool dialog box through the Set Tool Options command in the Layout menu while the tool is 
selected or by double-clicking on the Smudge tool button. You can use the slider bars or the up/down arrows to 
change the values or enter the numeric values directly through the keyboard when a field is selected. 
Pressure
As with the Smear tool, the Pressure setting in the Smudge dialog determines how colors are mixed. When the 
Pressure field is set to 30 percent, for example, paint is sampled from the area covered by the selected brush, 
mixed at a 30-70 percent ratio, then stamped back down on the Paint layer.
Step
Step determines how far a brush’s footprint overlaps its last as the brush is dragged across the document 
window. The value entered here represents a percentage of the brush footprint (in pixels). Settings less than 100 
percent will result in an increase in overlapping occurrences of paint.
Absorption
The Absorption field establishes how much paint is drawn into the selected brush as it passes over an area. At 50
percent, the brush absorbs half the paint it is dragged over. A low setting in this field will result in only a slight 
smudging effect while higher settings will produce more pronounced paint movement.
Presets
The Preset button will revert all fields in the dialog to their default settings.



The Sample Palette
The Sample palette displays the current colors, patterns, and brushes. It also provides pop-up palettes that let 
you select different brushes, colors, and patterns directly from the Sample palette. The pop-up palettes are 
designed to tear away from the Sample palette to provide easier access to their contents. You should note that 
you cannot edit the pop-up palettes or open new pop-up palettes while they are attached to the Sample palette. 
You must open them separately or tear them away to perform these operations.
The Sample palette, like all of MediaPaint’s palettes, is a free-floating palette you can move to any position on 
your screen. You can have the palette open at start-up wherever you want by turning on the Remember positions
button in the Preferences dialog. The Preferences dialog can be accessed through the Layout menu. You can also 
Show/Hide the Sample palette using the Show/Hide Sample command from the View menu, or by using the (Ctrl 
+ 2) keyboard shortcut. Clicking the Maximize box in the upper right-hand corner of the Sample palette toggles 
to Hide/Show the brush that is currently selected.
You should note that color and pattern selections made in the Sample palette’s various environments will not be 
visible if the pattern chosen for that environment is None. The None and Solid pattern selectors are located in 
the top, left corner of each pop-up palette while the palette is attached.
When the None pattern is selected, the affected area will appear transparent.
Sample box
The large filmstrip box on the right side of the Sample palette displays the current line width and color settings, 
fill color and pattern, and film color. Changes you make to any of these categories will be reflected in this sample
box.
As was mentioned earlier, the pop-up palettes containing fill colors, patterns, and brushes can all be accessed 
through the Sample palette as well as through the Show/Hide commands in the View menu. The color, pattern, 
and brush palettes can be torn from the Sample palette by clicking on the various selector boxes in the Sample 
palette and dragging the appropriate palette away.
Again, it is not necessary to tear the palettes away from the Sample palette to use them. If you prefer, or if 
screen space is limited, make color, pattern, and brush selections by simply clicking on the appropriate sample 
box, moving the cursor over the selection you want in the pop-up palette, and clicking the mouse to make the 
selection. You will notice the large sample box and the appropriate preview box will reflect changes in the color 
or pattern as your cursor moves over items in the selection palettes.
Fill color 
You can select a color from the Fill color pop-up palette. The Tints and Shades color palette will be loaded and 
open by default the first time you launch MediaPaint. To load other palettes at start-ups, simply place the palette 
in the Colors folder or directory.
You can select a color from the open Color palette on your desktop or by simply clicking the Fill color box and 
then clicking the color you want in the pop-up palette. The default fill color is white.
When working with gradient brushes, the Fill color is used in the black portions of the brush. White portions of a 
gradient brush use the Film color. Intermediate grays become transitional colors between the Fill and Film colors. 
For more information on gradient brushes refer to the Advanced Features of this manual.
Fill pattern
The Fill pattern pop-up palette contains the active pattern palette. When a fill pattern is selected the color in the 
center of the sample box changes to display the pattern. As with the color palette, you can access the pop-up 
pattern palette by clicking on the Fill pattern box and dragging the cursor across the palette. The default fill 
pattern is solid.
You should note that patterns will draw with the colors they are displayed with in the Pattern palette when the 
Paint As Is option is selected in the palette’s Command pop-up menu. To draw the pattern with the current Fill 
color, change this option to Paint With Current Colors (see the discussion on the Pattern palette for more 
information on these and other palette options).
Line color
You can select a color for lines from the Line color pop-up palette. The process of selecting a line color is the 
same as that used for selecting a fill color. The color will be displayed in the sample box as a border around the 
fill color. The default line color is black.
Line pattern
You can select a pattern for lines from the Line pattern pop-up palette. The line pattern will be displayed in the 
same manner as the fill pattern except it will appear as a border to the fill color in the sample box.
If you want to paint with a shape tool without a border line, simply select the None button from the pattern pop-
up palette. The default line pattern is solid.
Film color 
You can select a film color from the Film color pop-up palette. The selected film color will be previewed in the 



sample box behind the brush fill color preview box only if the Film pattern is set to solid.
The Film color is used to establish how images are selected in the active window. You also establish the Slip None
parameters with the film color. Please see the discussions on Paste Special and Slip functions for more 
information on these techniques. The default film color is white.
Film pattern
You can choose either Solid or None (transparent) from the Film pattern pop-up palette. The default film pattern 
is None. With this setting, no color will be previewed in the sample box.
It is not necessary to change the pattern to solid when using the Paste Film Color as None function from the 
Paste Special menu. This function works regardless of the film pattern setting.
Brush
This box displays the current brush selection. The brush you use can be one of the predesigned brushes in the 
MediaPaint package or a special brush you design. The ability to design brushes is a powerful tool that lets you 
create delicate images such as leaves, flowers, and other objects that you can stamp onto the Paint layer as 
easy as clicking your mouse.
The Brush pop-up palette contains the active brush palette and, like all the Sample palette pop-ups, can be torn 
away by dragging the palette off the Sample palette to another location on your screen.



The Color Palette
The Color palette displays the colors currently available for use. When you launch MediaPaint, the palette(s) 
contained directly in the application’s Colors folder will automatically load into memory. Palettes contained within
other folders at this level, such as those in the More Colors folder, will not be loaded at start-up to conserve 
memory. You can load palettes as needed from within the application after launch. You should note that although 
more than one palette may be loaded, only one palette can be active at a time. The active palette is always the 
last palette loaded.
You can Show/Hide Colors from the View menu, use the shortcut (Ctrl + 3), or tear it off the Sample palette.
Black or white paint can be selected from the reserved paint bar at the upper left-hand corner of the palette. 
Eraser paint and stencil paint are also available from the reserve paint bar. None of the selections in the reserve 
paint bar can be edited.
Opening a color palette
You can open other color palettes that have been saved on your hard disk drive from the active color palette. You
can also create a custom color palette through the New Color Palette command in the Color palette menu. Once 
you have created a new palette, or if you have added colors to an existing palette, choose the Save palette 
command from the color palette command menu to save the palette to your hard disk drive.
Adding colors to the palette
To add a new color to the active Color palette, simply choose the New color command from the color palette 
menu and design your custom color with the color dialog box. You can also edit existing colors on the active 
palette by choosing the Edit colors command from the color palette menu and making adjustments to the color 
when the Color dialog box is displayed.
Deleting colors from the palette
To delete a color from the active palette, choose the Delete color command from the color palette menu. You can
cancel a Delete command in any palette by pressing the Escape key. Pressing and holding the Alt key while 
deleting items in any palette allows you to make multiple deletions.
Selecting a fill color
Specify a fill color from the Color palette by clicking on any color in the active palette. If no Color palette is 
showing, you can click on the Fill preview box and click on the color you want on the pop-out color palette. You 
will notice the sample box and fill color preview box on the Sample Palette reflects your current selection.
Selecting a line color 
You may specify a line color by holding down the Ctrl key while clicking on a color on the color palette or by 
clicking on the line color preview box and clicking on the corresponding pop-up color palette. The line color 
preview box will change to match your selection. Also, the outer border of the fill color preview in the sample box
will reflect the new line color as well as changes to the line weight.
Selecting a film color
You may set the film color by holding down the Alt key and clicking on any color on the color palette or by 
clicking on the film color preview box and clicking on the corresponding pop-up color palette.
Selecting a background color
When you open a new MediaPaint document, the default background color is black. You can select a different 
background color by holding down the Shift key and clicking on the desired color in the color palette provided 
you do not have a movie loaded in the Movie layer. You should note that background color serves as a substitute 
for a movie. While you can always change the background color, it will not be visible through a loaded movie.
However, if the movie is smaller than the document window, the background color may be seen as a frame 
around the movie.
Background color is not the same as paint, which can be selected with a selection tool and moved or otherwise 
manipulated. As mentioned before, background color simply provides a canvas color to fill in behind the Paint 
layer in the absence of a movie. Other than changing the color of the entire background, this cannot be edited.
When visible, the background color you select will be recorded with your project when you save the file as a 
movie.
Eraser Paint
When eraser paint is chosen, all tools behave as erasers. Your eraser takes on all of the same characteristics as 
the tool you have currently selected. For example, if you painted with a brush that had soft edges, you could also
erase with a brush with soft edges instead of using the square eraser tool with its sharp edges.
You can use eraser paint with a gradient brush to create unique effects in your brush stroke (see Advanced 
Features for more information).



Stencil Paint 
Stencil paint is a powerful paint you can use for creating spectacular special effects. The unique nature of this 
feature deserves special attention, but you should remember that stencil paint is essentially the same as any 
other color used in MediaPaint.
Stencil paint is available only when an image, either a movie or image file, has been imported into the Stencil 
layer. Once imported to that buffer, stencil paint can be used to create video-in-video effects, still image overlays
through part or all of your project, and other impressive effects. 
If the image imported to the Stencil layer is a movie file, the stencil frames automatically move forward and 
backward as you step through the frames of your project. This happens whether you manually step through the 
project with the Step Forward or Step Backward options in the Movie palette or use the Auto Copy functions to 
advance frames. The Stencil layer will always be in synchronous time with the Movie layer. This is an important 
concept because, in the final product, it allows you to place a movie inside another movie.
Using stencil paint
1. Import an image into the Stencil layer.
Choose the Import command from the File menu and select the movie file or image file you want to load as 
stencil paint. When the file is selected from the dialog list, click the Stencil button at the bottom of the dialog box
and click Import.
The file will be loaded into a special memory buffer-the Stencil layer. You can view the imported stencil like a 
filmstrip by toggling the Show/Hide Stencil command in the View menu.
2. Choose the Set Stencil Position command from the Movie menu.
When you choose the Set Stencil Position command, the image loaded in the stencil buffer will be ghosted in the 
active window. You can use the cursor or arrow keys to move the picture around in the document window until it 
is positioned where you want. You only need to set the stencil’s position in one frame. The position is then 
translated to all frames of the Stencil filmstrip.
When you have the stencil correctly positioned, simply click anywhere outside the stencil’s marching ants 
marquee, click on any tool in the Tool palette, or press Return or Enter to commit the stencil’s new position.
3. Select a brush or tool.
You can use any brush or tool available with other colors to apply stencil paint to the Paint layer.
4. Select Stencil Paint from the Sample palette.
Stencil paint has its own button on the Color palette. Clicking on the button, which looks like a small piece of film
with a large letter “S” in the center, loads your brush or tool with stencil paint.
5. Paint the stencil on the active Paint layer.
When you begin to paint with the brush or tool you have selected, the image from the stencil buffer will be used 
as the color. It will appear on the Paint layer in the same position you established with the Set Stencil Position 
command. This technique allows you to paint as much of the stencil image into your current project as you want.
Once the stencil paint has been applied to the Paint layer it can be edited the same as other colors.
You can also change the alpha setting used for stencil paint through the Set Stencil Alpha command in the Movie 
menu. This option allows you to establish the global opacity of the stencil paint. Please see the Advanced 
Features section of this manual for more information on setting the stencil alpha options.
You can use the Set Chroma Key options in the Movie menu if you need to mask certain colors from the stencil 
image to create areas of transparency. This feature is explained in the Advanced Features section of this manual.
Color Palette Selector
The Palette pop-up is used to switch between currently loaded color palettes. The name of the active palette 
appears in the pop-up menu.
Command Popup Menu
The Command pop-up menu is used to open, close, create, and edit color palettes.
New Color Palette 
This command is used to create a new color palette. You may want to create a palette that contains only your 
favorite colors or a palette of specialized colors.
Creating a new palette
1. Choose New Color Palette from the Command popup menu.
A new, untitled palette will appear. The new palette will be empty other than a black and a white color patch.
2. Add colors.
Add new color patches to the palette using the New Color command (see the New Color discussion later in this 
section for more information).
3. Save the palette.
Once saved using the Save Palette command, the new palette can be opened and used in all MediaPaint 



documents.
Open Palette 
A dialog box will be displayed allowing you to load a palette. 
Opening a new palette loads it into memory. When you are returned to the work area the new palette will be 
active. Remember, you can load as many palettes as your memory permits, but only one can be active at a time.
Other palettes will appear in the Palette pop-up menu for selection.
Close Palette 
This command closes the active (currently selected) palette and removes it from the Palette pop-up menu. You 
can reload a closed palette using the Open Palette command.
Save Palette
This command saves the current palette. Use this command to save a new palette or an existing palette that has
been edited.
While you can save your palettes anywhere on your hard disk drive, it is suggested you keep them in the Colors 
folder inside your MediaPaint folder. This will make finding the palettes easier.
If you save the color palette in the Colors folder located inside of the MediaPaint application folder, the color 
palette is opened automatically the next time you start up MediaPaint. If you do not want it to automatically 
open, place it inside another folder.
New Color
The New Color command allows you to add a new color to the active color palette.
Creating a new color
1. Choose New Color from the Command popup menu.
The dialog will be displayed with the current fill color. Adjust the controls in the Color dialog until you have 
selected the color you want.
You can also use the Eyedropper tool (Color Picker tool) to sample a color from the paint or movie layer prior to 
choosing the New Color command. This will set the Color Picker to the sampled color. 
2. Click OK.
Clicking OK in the Color dialog will place the new color on the palette.
3. Repeat steps 1 and 2.
Add as many colors to the active palette as you want by repeating the last two steps.
Edit Color
The Edit Color command provides a way to edit an existing color. The edited color will retain the changes for the 
current session only unless you elect to save the palette before shutting down. If you have edited a palette you 
will be asked if you want to save the changes when you quit MediaPaint.
Editing a color
1. Choose Edit Color from the Command popup menu.
The cursor will change from an arrow to a grabber hand. Clicking on the color you want to edit will prompt the 
Color dialog. 
2. Adjust the color. 
Change the color using the Color dialog.
3. Click OK.
Clicking OK in the Color dialog will replace the old color with the edited color.
Delete Color
The Delete Color command allows you to remove any unwanted colors from your palette. Holding down the Alt 
key allows you to make multiple deletions.
Deleting a color
1. Choose Delete Color from the Command popup menu.
The cursor will change to a delete cursor. 
2. Place the delete cursor over the color you want to remove and click.
The color will be removed from the palette.
If you do not want the color permanently removed, do not save the changes to your palette.
View Small, Medium, Large
You can choose to view the color palette with small, medium, or large color patches. If the entire palette is not 



visible, you can resize the palette window or use the scroll bar on the right to view hidden colors. Changing the 
palette view size is valid only for the current session. The default view is Small.
Hide/Show Dividing Lines
You may choose to display your color palette with or without dividing lines. This selection is valid for the current 
session only. The default is Show Dividing Lines.



Pattern Palette
The Pattern palette displays the patterns currently available. Patterns are stored in the Patterns folder inside the 
MediaPaint folder. Palettes located directly at the Patterns folder level will automatically load when the 
application is launched. However, only the last palette opened will be active. Palettes stored within other folders 
in the Patterns folder will not load at start-up, but may be opened later.
You can Show/Hide Patterns from the View menu, use the shortcut (Ctrl + 4), or tear it off the Sample palette.
Select Solid or None from the upper left-hand corner of the Pattern palette. You will see the Sample palette’s 
sample box changes as you toggle between these settings. Setting the pattern selection to None removes 
patterns and color from the sample box. If the Line color/pattern is set to solid you can paint outlines with any of 
the shape tools.
You can also change the Solid/None settings for Fill and Line colors from the Sample palette. The Solid/None 
selection on the Pattern palette only affects the Fill color.
Pattern Palette Selector
The Pattern palette pop-up menu displays all currently loaded pattern palettes. You may designate any of the 
palettes listed as the active palette. Any new palettes you load using the Open Palette command after start-up 
will appear in this pop-up menu.
Command Popup Menu
The Command pop-up menu is used to open, close, create, and edit palettes. 
New Pattern Palette 
This command is used to create a new Pattern palette. You may want to create a palette that contains frequently 
used patterns or custom patterns you have created. New palettes you have saved to disk can be used with any 
MediaPaint document, not just with the currently opened document.
Creating a new palette
1. Choose New Pattern Palette from the Command popup menu.
A new, empty palette will appear. From the new palette’s Command pop-up menu you can add new patterns, 
edit patterns, and perform all other functions from within the palette’s command structure.
2. Save the palette.
Give the palette a unique name and save it in the Patterns folder for use in future sessions with the current, or 
another MediaPaint file.
Open Palette 
The Open Palette command allows you to load a palette into memory for use. After loading, this will become the 
active pattern palette. You can load multiple palettes, but only one can be active at a time. All loaded palettes 
will appear in the Pattern palette pop-up menu.
Close Palette 
This command closes the active (currently selected) Pattern palette and removes it from memory, which takes it 
off the Pattern palette pop-up menu. 
Save Palette
This command saves the current Pattern palette. Use this command to save a new palette or an existing palette 
that has been edited. 
If you save the pattern palette in MediaPaint’s Patterns folder, the pattern palette is loaded automatically when 
you launch the application. If you do not want the palette to open automatically, place it inside a subdirectory in 
the Patterns folder. MediaPaint will automatically load any palette saved directly in the appropriate folder. Those 
buried one level deeper in another folder will not be loaded, but are always available by using the Open Palette 
command.
New Pattern 
This command allows the user to add new patterns to an existing palette.
Creating a new pattern
1. Choose New Pattern from the Command popup menu.
When you choose the New Pattern command, a special Marquee tool will become active to allow you to select 
the new pattern.
2. Isolate the desired pattern by clicking and dragging a marquee box around the image.
Adjust the handles of the pattern selection box until the marquee is the size you want. The pattern selection box 
will snap to sizes supported for patterns (only pattern sizes that are a power of two are supported).
3. Position the pattern selection box.



You can reposition the pattern selection box by dragging the marquee with the grabber until it is aligned properly
over the image in the document window.
4. Click outside the pattern selection box or press Return or Enter.
The new pattern will be entered in the next available position in the active pattern palette.
Delete Pattern
Use this command to remove unwanted patterns from your active palette. Holding down the Alt key allows you 
to make multiple deletions.
Deleting a pattern
1. Choose Delete Pattern from the Command popup menu.
The cursor will change to a delete cursor. 
2. Place the delete cursor over the pattern you want to delete, and click.

The selected pattern will be deleted from the palette.
Paint As Is
Selecting Paint As Is from the Command pop-up menu will cause patterns to be drawn in the colors shown on the
Pattern palette. The default setting is Paint As Is.
Paint With Current Colors
Selecting the Paint With Current Colors command will replace the colors in the selected pattern with the current 
fill and film colors displayed in the Sample palette.
View Small, Medium, Large
You can display the patterns as small, medium, or large pattern tiles. If the entire palette is not visible, you can 
resize the palette window or use the scroll bar to view hidden pattern tiles. 
Changing the view size of the palette is valid only for the current session. The default view is medium.



The Brush Palette
MediaPaint allows you to paint with an endless variety of brushes. You can use any of MediaPaint’s predesigned 
brushes or create your own custom brushes for any project.
When you launch MediaPaint, the palettes contained in the Brushes folder’s root window will automatically load. 
Palettes contained in other folders within the Brushes folder will not be loaded at start-up but may be opened 
later. 
You can Show/Hide Brushes from the View menu, or use the shortcut (Ctrl + 5).
Brush Palette Selector
The Palette pop-up is used to switch between currently loaded brush palettes.
The name of the active palette appears in the pop-up menu.
Command Popup Menu
The Command pop-up menu is used to open, close, create, and edit brush palettes.
New Brush Palette 
This command is used to create a new brush palette. You create a new palette for brushes the same way you 
create new palettes for colors and patterns. The brushes you save to the new palette can be of a standard type 
or specialized types such as gradient brushes.
Creating a new palette
1. Choose New Brush Palette from the Command popup menu.
A new, empty palette will appear. You can add new brushes or perform any other function available in the 
palette’s Command pop-up menu.
2. Save the palette.
If you fail to save the palette prior to quitting the application, any brushes you added during the session will be 
lost.
Open Palette 
Choosing the Open Palette command allows you to load a brush palette into memory for use in the current 
project. Select the palette you want to load from the Brushes folder inside the MediaPaint folder. After loading, 
the new palette will become active. As with all MediaPaint palettes, you can load as many as memory permits, 
but only one can be active at a time. All loaded palettes will appear in the Brush palette pop-up menu.
Close Palette 
This command closes the active Brush palette and removes it from memory and the pop-up menu. 
Save Palette
This command will save the active Brush palette to your hard disk drive. Use this command to save a new or 
existing palette. You should save new brush palettes in the Brushes folder. Those saved directly in the Brushes 
folder will automatically be loaded each time the application is launched. Palettes buried deeper in the Brushes 
folder, such as those inside the More Brushes folder, will not be loaded unless you load them using the Open 
Palette menu.
New Brush 
As the name implies, this command allows you to add new brushes to an existing palette. Brushes can be 
created for almost any project. Having a ready-made cache of special brushes can be a great time saver and will 
help you create special effects quickly and easily.
You should note a brush can be any shape and contain colors or gray images. This allows you to create a tool for 
creating such images as leaves. You can also create and save gradient brushes that can paint with multiple 
colors in one pass.
Creating a new brush
1. Select all or part of a painted image in the document window
If no paint has been selected, the New Brush command in the menu will be dimmed and will not be available to 
you. Paint must be selected before you can create a new brush.
2. Choose New Brush from the Command popup menu.
The image you selected is copied, converted to a brush, and placed in the active brush palette. Once the brush is
part of the brush palette you can select it and paint as you would with any of the predesigned brushes that came
with the MediaPaint package.
Delete Brush 
Use this command to remove unwanted brushes from your active palette. 



Deleting a brush
1. Choose Delete Brush from the Command popup menu.
The cursor will change to a delete cursor. 
2. Place the delete cursor over the brush you want to delete, and click.
The brush will be removed from the active palette.
If you save the changes to the palette when exiting the program, the brush will be permanently removed. 
However, if you do not save the changes to the palette prior to exiting, the deleted brush will be available the 
next time you launch MediaPaint.
Paint As Is 
Selecting Paint As Is from the Command pop-up menu allows you to paint with the color of the brush as it 
appears in the brush palette.
Paint With Current Colors
To colorize the brush with paint from the current fill and film colors, select Paint With Current Colors. The Sample 
palette displays the current color selections. The default setting is Paint With Current Colors.
Because all brushes are created equal in MediaPaint (that is, black pixels get the Fill color and white pixels get 
the Film color), this option also applies to gradient brushes. When this option is selected, gradient brushes will 
use the current Fill and Film colors.
View Small, Medium, Large
You can display the palette with small, medium, or large sample brushes. If the entire palette is not visible, you 
can resize the palette window, or use the scroll bar to show the hidden brushes. Changing the view size of the 
palette is valid only for the current session. The default view is Small.
Hide/Show Dividing Lines
You can display your brush palette with or without dividing lines. This selection is valid for the current session 
only. The default is Show Dividing Lines.



Info Palette
The Info palette window displays information useful for precise navigation in the document window. The indicator
fields show cursor position, starting brush point, distance moved, and other information. 
The horizontal and vertical positions indicated in the Info palette are measured along the X and Y axis of the 
document window. These measurements indicate the cursor location from the 0,0 grid positions, which are in the
top, left corner of the document window.
You can Show/Hide Info from the View menu, or use the shortcut (Ctrl + 6).
Using pointer position information

· Horizontal pointer position shows the cursor position from the left (zero) grid line of the document window.
· Vertical pointer position shows the cursor position from the top (zero) grid line of the document window.
· Width pointer indicates the distance the cursor has traveled along the X (horizontal) axis from its starting 

position in the document window.
· Height pointer indicates the distance the cursor has traveled along the Y (vertical) axis from its starting 

position in the document window.
· Distance pointer shows the actual distance the cursor has moved from the point where the mouse button was

first depressed accounting for curves as well as lineal travel.
· Angle of movement pointer shows the cursor’s current grid position in relation to its starting point. The 

measurement is calculated by marking the position you click the primary mouse button as the angle’s vertex 
point. Exact vertical travel is measured as movement along the 0/360 degree or 180 degree line (upward 
movement from the start point is along the 0/360 degree line while movement downward from the start point 
is along the 180 line). Exact horizontal travel is measured along the 90 degree (right of the start point) or 270 
degree (left of the start point) line.

Filmstrip work area information
In addition to the cursor position information, you can click the zoom box in the upper right-hand corner of the 
Info palette for information about the In and Out points and project length.

· In point position is the beginning frame of your movie.
· Out point position is the ending frame of your movie.
· Project duration displays the total time your movie will run (based on frames per second).

You can change the unit of measure used in the Info palette through the Set Units options command in the 
Layout menu. Simply check the Show unit label in Info Palette box in the Set Units dialog and the selected units 
of measurement will be displayed in the Info palette.



The Movie Controls Palette

This is the palette used to move through your project. The controls on this palette operate similar to the controls 
on a VCR and include Play/Pause, Record, and Rewind. 
You can Show/Hide Movie Controls from the View menu, or use the shortcut, (Ctrl + 7).

See Also
Time Code 
Record 
Go To Start 
Step Backward 
Play/Pause 
Step Forward 
Go To End 
Frame Rate 
Relative Jog Shuttle 
Absolute Jog Shuttle 
Auto Copy Mode 
LightBox on/off 



Time Code
The SMPTE (Society for Motion Picture and Television Engineers) time code displays the current frame shown in 
the document window. Frames are numbered according to the actual time it takes to reach that point from the 
first frame in the normal play mode.
In the SMPTE time code, the first number is hours, the second is minutes, the third is seconds, and the last 
number represents the frame number within that second. You can use the time code as a precise way to track 
various events in your movie and to time the duration of a movie or effect.
Clicking once on the Time Code box will open the Go To Frame dialog box. You can enter the actual frame number
or the time code of the frame in the dialog to jump to that point in the movie.



Record
One of MediaPaint’s most powerful features allows you to paint on a movie as it is playing. In effect, you can 
view your movie while recording paint at the same time.
Recording paint
1. Choose a painting tool in the Tool palette.
You should also ensure you have selected the color, pattern, and brush you want to paint with.
Click the Record button in the Movie Controls palette.
This prompts MediaPaint of your intent to record an activity. Note the Record button flashes until you start 
painting to signal you the application is waiting for you to begin.
3. Start painting in the document window.
MediaPaint waits until you start painting before it starts playing any movie you have loaded in the Movie layer. 
As soon as you click in the document window with your brush the movie begins playing. Everything you lay down
on the Paint layer is recorded in synchronous time with the movie.
There does not need to be a movie loaded to the Movie layer to use this feature.
4. When you are through painting, click the Stop button on the Movie Controls palette.
This will stop the recording on the current frame. You do not have to continue the recording to the end of the 
movie.
You can also press the Control-key shortcut Ctrl + . (period) to stop the recording.
You should note that pressing the Escape key will pause the recording until you begin painting again. 
5. Click the Go To Start button on the Movie Controls palette.
This will rewind the movie to the first frame.
6. Click the Play button on the Movie Controls palette.
When you play the sequence back you should see the movie and the paint you just applied.



Go To Start
Clicking on this button will take you to the beginning frame (the In point) of your project. The first frame will be 
displayed in the document window.



Step Backward
Clicking on the Step Backward button jumps the document window back a single frame at a time.
If you hold down the Alt key while clicking on the Step Backward or Step Forward button, a copy of the selected 
paint is left behind on the current frame before you go backward or forward to the previous or next frame.



Play/Pause
This control toggles between the Play and Pause modes.



Step Forward
Step Forward moves the document window display to the next frame each time you click on this button.



Go To End
This button moves the document window to the last frame (Out point) of your movie.



Frame Rate
The frame rate on the movie control palette is used for editing purposes only. The speed at which the Movie file 
was originally recorded cannot be changed until you save the project as a movie file. You can, however, select 
the number of frames per second (or seconds per frame) to playback your animation through the pop-up frame 
rate menu. This is helpful when you are reviewing your work or recording your paint strokes as the movie plays. 
You can also set the frame rate to play your movie at various seconds per frame, which pauses at each frame for
the selected number of seconds before proceeding to the next frame.
While you are recording paint, the frames may go by too quickly for you to paint the graphics you want on each 
frame. To slow down how quickly the frames go by, choose a slower frame rate from the Frame Rate pop-up 
menu in the Movie Controls palette. This will give you more time to paint on each frame. After you are finished 
recording you may want to review your work at a faster frame rate.



Relative Jog Shuttle
Use the Relative Jog Shuttle to move to a position relative to the frame you are currently viewing. Dragging the 
Relative Jog Shuttle slider slightly to the left will display frames located before the current frame. Dragging the 
shuttle to the right will display frames after the current frame. Note the time code display indicates your new 
position within the filmstrip based on the In/Out points.



Absolute Jog Shuttle
Use the Absolute Jog Shuttle slider to move to a specific position within a project relative to the In and Out 
points. Moving the shuttle all the way to the left will display the beginning frame while dragging the slider all the 
way to the right will display the last frame. The time code display will update as you move the slider to show 
your new position within the document.



Auto Copy Mode
MediaPaint will automatically copy paint from frame to frame when the Auto Copy option is turned on. You can 
specify whether to copy just the new paint you have applied or all the paint from the active window’s Paint layer.
It is important to understand the concept of new and old paint to fully grasp why some paints are copied across 
frames when using the Auto Copy New option and others are not. The following discussion about new and old 
paint should provide a better understanding of how these concepts come in to play when using MediaPaint’s 
Auto Copy and Paste Special functions.
New and old paint
New paint is all paint you laid down on the last active frame during a single session. In other words, fresh paint 
you lay down in the active frame is not considered new paint until you leave that frame and activate another. 
The paint you applied in the last active frame during that session is pulled into a buffer when you leave the 
frame. If you change the active window by stepping forward with Auto Copy New turned on, the paint stored in 
the buffer is automatically placed in the new window. If Auto Copy is turned off, you can move to any frame, 
forward or backward, and use the Paste New From Last command from the Edit menu’s Paste Special pop-out 
submenu to place the paint from the buffer onto the new active Paint layer.
New paint stored in the buffer is replaced each time you change active frames. Only the paint from the last 
active frame is held in the buffer.
For example, if you paint in frame one then move to frame two, the paint you laid down in frame one is stored in 
the buffer and taken along for the ride. If you then return to frame one, the paint applied while working on frame 
two is pulled into the buffer, replacing the previously stored paint. The paint on frame one’s Paint layer is now 
considered old paint.
You should note that simply activating another frame does not replace the paint stored in the buffer. You must 
take some action, such as laying down paint, pasting paint, or even just selecting an object while in the new 
frame for the buffer to be updated. 
Old paint, then, is that paint no longer stored in the new paint memory buffer. You cannot use the Paste New 
From Last or the Auto Copy New commands to copy old paint from frame to frame. However, old paint, along 
with any new paint, can be copied to other frames using the Paste All From Last and Auto Copy All commands.
You can also access the Auto Copy options from the Movie menu.
Auto Copy New
The Auto Copy New function copies only new paint stored in the new paint memory buffer to other frames as you
advance through the project using the step forward button on the Movie Control palette or the right arrow key on
the keyboard. The Auto Copy New function does not copy old paint (please see the previous discussion on new 
and old paint). 
To use the function, simply turn Auto Copy New on from the Movie Control palette (you can also turn on the 
option from the Movie menu) and click on the Step Forward button to advance to the next frame. All new paint 
from the previous window will automatically be copied and placed in the new window as you step forward. New 
paint copied forward with the Auto Copy New function will be placed on top of any old paint on the frames.
If you want to include old paint in the Auto Copy New operation or Paste New From Last command, simply select 
the old paint you want included, then deselect the paint. Remember, when paint is selected it is removed from 
the active Paint layer until you commit the paint back to the Paint layer by deselecting it, which makes it new 
paint to that layer.
Auto Copy All
The Auto Copy All function works similar to Auto Copy New except it copies all paint from the last active window 
and applies the copied paint to adjacent frames as you advance using the step forward control. This function 
works on the axiom “what you see is what you get.” Everything on the current Paint layer will be copied to the 
next frame when you advance with Auto Copy All turned on. If there is already paint on the new frame’s Paint 
layer, the copied paint will be placed on top of the existing paint and everything will be copied to the next frame 
when you step forward again. If stencil paint was used, the paint will automatically be updated as you step 
forward as long as the stencil paint is new paint.



LightBox on/off
Clicking on the LightBox button toggles the LightBox on and off. 
The LightBox feature allows you to see ghosted or onion-skinned images from other frames of the filmstrip. This 
makes it easy to accurately paint objects that span a series of frame in their proper position relative to other 
frames.
When the LightBox is turned on, images from previous and future frame(s) are shown in the active window as a 
ghosted image. The image is not part of the active window’s paint layer and will not be copied to that frame. 
However, it allows you to paint objects so they line up with objects on previous and future frames.
The LightBox settings
You can change the settings of the LightBox to ghost numerous frames before and after the currently active 
frame. You can also adjust the transparency of each frame’s occurrence in the active window through the 
LightBox Settings command in the Arrange menu. 
Back
The Back field sets how many previous consecutive frames will be ghosted in the current window when the 
LightBox is turned on. Generally, two to three previous frames are enough, but there may be cases when you 
want to set this number higher.
You can enter the number in the field manually from the keyboard or use the arrows to adjust the number up or 
down.
Forward
The Forward field sets how many future consecutive frames will be ghosted in the current window when the 
LightBox is turned on. This is helpful when you need to see images from the next frame of the movie in the 
current window.
You can enter the number in the field manually from the keyboard or use the arrows to adjust the number up or 
down.
Initial Opacity
This field sets the opacity of the ghosted images from frames adjacent (immediately forward and back) to the 
active window. For example, a setting of 50 percent here will make the ghosted image appear at half its original 
opacity (or twice its original transparency). A setting of 100 percent will make the ghosted image appear the 
same as the original, which could make it difficult to discern from objects you are painting on the active Paint 
layer.
You can enter the number in the field manually from the keyboard or use the arrows to adjust the number up or 
down.
Fade Each Layer By
This field allows you to fade the opacity of consecutively distant frames by a percentage of the Initial Opacity 
field. In other words, the farther the ghosted frame is from the active frame, the more transparent it will appear 
if the Fade Each Layer By setting is less than 100 percent.
For example, if the Initial Opacity is set to 50 percent and the Fade Each Layer By is set to 50 percent, the image 
from adjacent frames (one frame forward or back of the active frame) will appear at half its original opacity and 
the next frames out (two frames forward or back from the active frame) will appear at one quarter its original 
opacity. Images three frames out would be ghosted at an eighth their original opacity and so on.
You can enter the number in the field manually from the keyboard or use the arrows to adjust the number up or 
down.



Strokes Palette
The Stroke feature allows you to paint a smooth, continuous line over time in selected frames. The feature is not 
tool or color specific because only the path of the brush or tool is recorded. Once the path is stored in the 
palette, you can use any brush, tool, and color to recreate the path of the stroke. The recreation can be done on 
a single frame or across a range of frames.
You must use the Strokes palette to create or use a stored stroke.
Using the Strokes palette
Before you begin, choose the Show Strokes command from the View menu to open the Strokes palette. 
1. Select any brush or tool and color you want to use to create your stroke.
As was mentioned earlier, you can use any tool or brush to create a stroke’s path.
2. Choose the New Stroke command from the Strokes palette Command popup menu.
Everything you draw in the active window will now be recorded as a path until you end the stroke session.
3. Drag the brush along the path you want your stroke to follow.
As you drag the brush or tool you selected, the path will be recorded.
4. Choose the End Stroke command from the Strokes palette Command popup menu.
This will end the session and place a representation of the path on the palette.
Your stroke is now ready for use. To use the stroke, simply select a tool, set your fill color, choose the stroke, and 
click in the active window. The recorded stroke will be redrawn just as you originally painted it except the new 
version will use the currently selected tool and color.
Painting a stroke over a range of frames
The Filmstrip window must be open to paint a stroke over a range of frames. To show the filmstrip, select Show 
Filmstrip from the View menu.
1. Select a range of frames on which to paint the stroke.
You can set the frame range by clicking on the first and last frames while hold down the shift key.
2. Select the tool or brush and color to be used for the stroke.
You can use any tool or brush to recreate the stroke. The selections you make do not have to be the same you 
used to create the stroke’s path.
3. Select Auto Copy New from the Movie Controls palette to make the stroke a continuous line that flows 
over time.
If Auto Copy New is not selected, those portions of the stroke painted on previous frames will not be copied over 
to the next. This will cause your stroke to appear as a series of animated lines, each picking up where the last 
left off and moving to some new point in the active window where it will stop and the next line will begin. Each 
line’s birth and death points in this scenario correspond to when one frame advances to the next. You may want 
to try the stroke without using Auto Copy just to see what happens.
4. Select the stroke from the Strokes palette and click in the active window. 
You will be prompted that the process cannot be undone. Press Proceed to continue.
The application will draw the stroke with the selected tool and colors across the range of selected frames. The 
stroke will be broken into segments across the entire range of frames. However, the segments may not be the 
same length because the software segments the line by counting the number of reference points along the path.
The points are then equally divided between the frames.
You can also paint a stroke while recording. Make your tool and color selections. Select Autocopy New. Click 
Record (MediaPaint will wait until you click in the document window). Select your stroke, position it in the 
document window and click. Click the stop button when you are done.
New Stroke Palette
New Stroke Palette creates a new, clean palette for storing strokes. To create a new palette, select New Stroke 
Palette from the Stroke palette’s Command pop-up menu.
Open Palette
The Open Palette command allows you to open a saved Stroke palette. To open a palette, select the Open Palette
command, located and select the palette you want, and click Open.
Close Palette
The Close Palette command closes the active Stroke palette. To close the palette, select the Close Palette 
command from the Stroke palette’s Command pop-up menu.
Save Palette
This option saves the currently active palette. To save a palette, select Save Palette from the Command pop-up 
menu, name the palette, and click the Save button.



New Stroke
This command begins a stroke recording session. Once you have selected this command, everything you do in 
the active window will be recorded as the stroke until you end the session with the End Stroke command. 
End Stroke
This command ends a stroke recording session. Once you have selected this command, the current session will 
end and a representation of the stroke’s path will appear in the active palette.
The New and End Stroke commands do not appear simultaneously in the Command pop-up menu. Only the 
pertinent command will be displayed. For example, if the menu displays the End Stroke command, you are 
currently involved in a stroke recording session.
Delete Stroke
This command allows you delete strokes from the active palette. To delete a stroke, select Delete Stroke from the
Command pop-up menu and click the delete cursor on the stroke to be deleted.
View Small, Medium, Large
These commands change the size of the tiles the strokes are displayed on for easy viewing. Changing the view 
size of the palette is valid only for the current session. The default view is small.
Hide Dividing Lines
This command hides the tile borders to show only strokes. Select it under the Command pop-up menu on the 
Stroke Palette and the lines will automatically disappear. Select Show Dividing Lines to make the borders 
reappear.



Chapter 4
Editing Documents

 Introduction

MediaPaint offers a wide range of techniques to make editing your projects as simple as possible.
Unlike some applications, you can never damage or destroy your original movie. Your movie always remains 
untouched on the Movie layer.
This chapter will outline methods of editing your document to achieve the results you want in the most effective 
manner.
MediaPaint is designed to allow you more than one way to accomplish a particular task, so you may want to 
experiment to discover which methods work best for you.



Using the Grid
You can choose whether or not you want to use a grid while you work on your document by using the Turn Grid 
On/Off from the Arrange menu. You can also define the dimensions of your grid as you progress through your 
project.

Changing the grid settings 
1. Select Set Units from the Layout menu.
This will prompt the Set Units dialog box.
2. Select the measurement system.
You can choose from Pixels, Inches, or Centimeters by clicking on the corresponding option in the dialog box.
3. Select the grid size.
The Grid Size will affect the various MediaPaint tools which allow you to set the Step tolerance for that tool when 
the grid is turned on. The Step tolerance setting tells a tool how often to lay down paint as the tool is dragged 
across the active window (please refer to the tool descriptions in the Palettes chapter for more information on 
Step). 
4. Click the “Show unit label in Info Palette” checkbox .
If you leave this checkbox turned off, the Info palette will display the numbers without labels.
5. Click OK to make your selections active and return to the document window.



Changing the View
There are several methods for increasing or decreasing the viewing size of your work. The following 
magnification levels are available: 25, 50, 100, 200, 400, 600, and 800 percent.
The Zoom tool
Select the Zoom tool from the Tool palette. Your cursor will change to a magnifying glass you can place over the 
area you want to magnify. Simply click the left mouse button, and the view will increase to 200 percent. Clicking 
again will increase the magnification to 400 percent, then 600 percent, and finally 800 percent. Each time you 
click, the view increases to the next available magnification level.
To reduce the magnification level, hold down the Alt key while clicking in the document window with the Zoom 
tool. The view will decrease by one magnification level.
Double-clicking on the Magnify tool will toggle between actual size and 800 percent.
The Zoom tool will center the new view on the area you clicked.
The Zoom In/Zoom Out buttons
These buttons are located left of the horizontal scroll bar in a document window.
Clicking on the Zoom In button enlarges the view of a document to the next larger magnification level.
Clicking on the Zoom Out button reduces the view of a document to the next smaller magnification level.
The Zoom Level Pop-Up menu

This menu contains commands for each magnification level. You can view your document at any of the 
magnification levels available in this menu.



Selecting Paint
MediaPaint provides two tools for selecting paint: the Marquee tool and Lasso tool. Double-clicking on either of 
these tools will select all paint in the active document window.
Paint can be selected from the Paint layer, the Movie layer, or both. The following example will help clarify the 
process of selecting paint from different layers in your document.
You should note that pressing the Backspace key while paint is selected will remove it from the active document. 
Choosing Undo from the Edit menu or using the keyboard shortcut Ctrl + Z immediately afterwards will void the 
action and place the selection back in the document.

Selecting paint
1. Import a movie into your document, and apply some paint to the current frame.

Use any tool to apply paint to the active frame in the document window. You can use any paint color you want
for this example.

2. With the Paint layer still selected on the Layer mode pop-up menu, select the paint with the Marquee or Lasso
selection tool. Then move the paint.
The paint will move freely in the document window over top of the movie displayed in the background. Where 
you choose to relocate the paint in the active window does not matter for this demonstration.
Click in the active window to deselect the paint and commit it back to the Paint layer. 

3. Select the Movie layer from the Layer mode pop-up menu.

This will make it possible to copy images directly from the Movie layer to the Paint layer.
4. Select an area of the movie.

Draw a marquee around the paint you applied while in the Paint layer mode. You will notice that paint seems 
to disappear. Actually, it is simply covered by the active selection.
While in the Movie layer mode, MediaPaint samples colors from the Movie layer. 
The selection becomes new paint on the Paint layer when it is committed, leaving your original movie 
untouched.
Remember, a selection is not part of any frame until it has been stamped down or committed by deselecting 
it.

5. Move the selection to see the first paint you laid down. 

While the images copied from the Movie layer are still selected, drag the selection to another location in the 
active window. You will notice that only the copied paint from the Movie layer is moved, letting you see the 
previously painted colors that were temporarily covered.
You can place the active selection anywhere in the document window, including on top of other paint. When 
you have the paint located where you want, deselect it by clicking outside the selection to commit the new 
paint to the Paint layer.

6. Choose the Movie and Paint layer from the Layer mode pop-up menu and select an area.
Draw your selection marquee to include at least part of the paint you placed on the Paint layer and an area 
where no paint has previously been placed. Where no paint existed on the Paint layer, this mode will copy the 
colors from the Movie layer as part of the selection.
Drag the selection to a new location. You will notice that both the paint you previously applied and the new 
paint copied from the Movie layer are moved. In this mode, colors copied from the Movie layer remain under 
previously existing paint.
You can also choose the Select All command from the Edit menu with layer modes. When the document 
window is active, all paint in the current frame is selected. If the layer mode is set to Movie layer, all paint 
from the Movie layer is selected; if the layer mode is set to Paint and Movie layer, all paint from both layers is 
selected with the Select All command. 
When the Filmstrip is active (rather than the document window), the Select All command will select all frames 
in the Filmstrip.
Select None is also available from the Edit menu to deselect all current selections.



Hide/Show Selection Border 
When you select an area of paint, that area is normally outlined by an animated “marching ants” border. While 
this border makes it easy to distinguish the selection from other paint, it sometimes makes it difficult to work with 
the very small selections. In these cases, you can hide the animated border by selecting Hide Selection Border 
from the Edit menu. Even though the border is not visible, the cursor will be transformed to an arrow as you move 
the cursor over the selected area, allowing you to move the selection as you would normally.
To make your selection border visible again, choose Show Selection Border from the Edit menu.



Moving a paint selection
You can easily move paint from one area to another within the active document window by selecting an area of 
paint with a selection tool, clicking, and then dragging the selection to another location.
When you move the cursor on top of the selected area, the cursor will change to an arrow. You can click-and-drag 
the selection anywhere within the active window. When the paint is positioned where you want it, deselect the 
paint by clicking anywhere outside of the selection. Paint is not committed to the Paint layer until it is deselected.
To move the entire paint selection up, down, left, or right one pixel at a time, hold down the Ctrl    key and press 
the up-arrow, down-arrow, left-arrow, or right-arrow key respectively. Use Shift + Ctrl + [arrow key] to move the 
entire selection 10 pixels at time.
When working with extremely small areas of selected paint, the arrow itself may interfere with your placement of 
the selection. To avoid this problem, position the cursor a reasonable distance from the selection. Hold down the 
Ctrl key and depress the left mouse button. The selection will move freely in conjunction with the cursor arrow. 
When the selected paint is positioned where you want it, release the mouse button and deselect the paint.



Flipping a paint selection
You can flip a paint selection horizontally or vertically. Flipping a selection creates a mirror image along either the 
horizontal or vertical axis. Choose Flip Horizontal or Flip Vertical from the Arrange menu to perform the operation.



Rotating a paint selection
MediaPaint offers you four choices for rotating paint selections. The Rotate commands are available under the 
Arrange menu. You must have paint selected in the active document window to access the Rotate commands.
· Rotate Right
To rotate a paint selection 90 degrees clockwise (to the right), choose Rotate Right from the Arrange menu.
· Rotate Left
To rotate the selection 90 degrees counterclockwise (to the left), choose Rotate Left from the Arrange menu.
· Rotate Free
Select Rotate Free from the Arrange menu to manually rotate your paint selection to the desired position. Place 
the cursor on one of the corner handles and rotate the selection to the desired position.
· Rotate by Angle
You can rotate a paint selection a specific number of degrees around the center point of the selection by choosing 
the Rotate by Angle command from the Arrange menu. To do this, enter a value from -359 to 359 degrees. 
Entering a negative number will cause the selection to rotate counterclockwise. A positive number in the field will 
rotate the selection clockwise.



Resizing a paint selection
Selected areas of paint can be resized using either of two resizing methods.
· Resize Free
After selecting Resize Free from the Arrange menu, four selection handles will appear on the paint selection. 
Position the cursor over any of the handles and click-and-drag the selection box to the size you want. Notice the 
image is scaled to fit within the resized marquee.
· Resize by Percent
This option, which is also found in the Arrange menu, allows you in enter an exact percentage by which to 
increase or decrease the size of the selection.

Absolute - Click on this choice to enter an absolute value for resizing the selected paint. Enter a percentage from 1
to 1000. Scaling an object 50 percent decreases the size by half its original size while setting the field to 200 
percent doubles the size of the selection.
Relative - Use this method when you want to specify by what percentage you want the size of the selected paint 
to be increased or decreased. Entering a positive number will increase the size of the selection; a negative 
number will decrease its size.
In other words, the object will be scaled relative to its current size. Entering 50 percent in the Relative percentage 
box will result in the selection being resized to its original size plus 50 percent (the equivalent of entering 150 
percent in the Absolute box). Entering a -25 will result in the selection being resized to its original size minus 25 
percent (the equivalent of entering 75 percent in the Absolute box).
Independently - You can also choose to specify a separate percentage for the height and the width of the 
selection. In this case, click the Independently button and enter the appropriate values. This option will scale the 
selected object using the Absolute criteria.



Copy, Cut, and Paste
Copying, cutting, and pasting in the active window works much like it does in other applications. When you select 
an area of paint and use the Cut or Copy commands, the selection is stored on the clipboard and will remain there 
until it is replaced by another selection which has been Cut or Copied. Only one selection can be present on the 
clipboard at a time. Therefore, only the last selection remains on the clipboard.
With one of the selection tools (the Marquee or the Lasso tool), select the area of paint to be copied or cut and 
select the Copy or Cut command from the Edit menu. The selected paint is placed on the clipboard. When you are 
ready to put a copy of the clipboard back into your document window, select Paste from the Edit menu. To position
the selection, move it with the arrow and click to deselect it. Remember, the paint will not be committed to the 
Paint layer until the selection has been deselected.
In addition to using the Copy and Paste commands to duplicate an area of paint, you can use the Alt-drag 
technique. Alt-drag will leave a copy of the selected paint behind as you move the selection to a new position in 
your document window.
To use this method, simply select the paint to be copied and, with the Alt key depressed, move the selection to its 
new position. Once again, the paint must be deselected before it is actually placed on the Paint layer.



Copy paint frame to frame
In addition to copying paint using the conventional Copy and Paste method, you can also copy paint from one 
frame to another without using the Copy and Paste commands.

Copying frame to frame
1. Select an area of paint you want to copy.
You do not use the Copy command to use this method.
2. Hold the Alt key down and step to the next frame.
Holding the Alt key down while clicking on the Step Forward button will stamp a copy of the selected paint on the
frame you are leaving in the same position as the selection. The selected paint will move forward as you 
advance to the next frame.
You will not see the stamped copy while you are in the current frame. To see the stamped image as you advance,
choose the Show Filmstrip command in the View menu and watch the frames as you step forward.
3. Continue to Step Forward to the frames to which you want the selection copied.
You do not have to copy the paint on each frame as you step forward. Hold the Alt key down as you step forward 
only when you want a copy of the paint left behind on that frame. The selection will move forward as long as it 
has not been deselected. When you get to the last frame you are copying paint to, click in the document window
to deselect the paint and commit it to the active frame.
This function works in either direction, which means you can step forward or backward through the filmstrip. You 
can also jump to nonadjacent frames while holding the Alt key and the selection will be stamped to the active 
frames as you leave them.



Copy and Paste in the Filmstrip window
You can copy and paste entire frames of paint in the Filmstrip window. The Filmstrip window must be active to 
perform this function. If the Filmstrip window is not visible, choose Show Filmstrip from the View menu. 



Copying/pasting in the Filmstrip window
1. Select a frame in the Filmstrip window.
Select frames in the Filmstrip window by clicking anywhere in the frame or time code label above the frame.
You can select multiple frames in the Filmstrip window by clicking in the first frame you want and holding down 
the Shift key as you select additional frames. If you hold the Shift key and select two nonadjacent frames, all 
frames between the two will be included in the selection.
2. Choose Copy from the Edit menu.
This will place a copy of the selection on the clipboard.
3. Select the frame you want to place the copied paint onto.
If you are working with a multiple-frame copy, the frame you select here will serve as the beginning frame.
4. Choose Paste from the Edit menu.
The frame(s) of paint on the clipboard will be pasted in the selected frame. With multiple-frame copies, the 
images will be pasted in sequence with the currently selected frame as the beginning point.
You cannot paste frames selected and copied from the Filmstrip window into a document window. However, you 
can copy a selection from a document window and paste it into the Filmstrip window.



Copy/pasting from the document window to multiple frames
You can copy paint selections to the clipboard and paste them to one or more frames.
1. Select paint in the active document window.
2. Choose Copy from the Edit menu.

The selected paint will be placed on the clipboard.
3. Choose Paste To from the Edit menu.

The Paste To dialog box will appear, prompting you to select from a wide variety of Paste To operations.
4. Select where you want to paste the copied paint.

All Frames
To paste to all frames in the Filmstrip window, click All Frames.
Selected Frames
To paste the copied paint to the selected frames in the Filmstrip window, click Selected Frames. 
The contents of the clipboard will be pasted to only those frames which are currently selected in the Filmstrip.
Relative Range
To paste to a number of frames relative to the currently selected frame, click Relative Range and enter the 
number of frames, or amount of time, to paste to.
The Next and Previous buttons allow you to paste the selection before or after the currently selected frame.
Absolute Range
To paste to one or more frames at a specific point in time, click Absolute Range and enter the actual frame 
numbers, or time, to paste to.
Skip
To skip frames during the paste operation, click Skip and enter the number of frames, or a time duration, to 
skip while pasting. For example, Paste 1, then skip 2 would paste one frame, skip two frames, paste another 
frame, skip two more frames, etc. Paste 1, then skip 1 would paste the copied paint on every other frame.
Paste As Stencil
Turning this checkbox on will replace the copied paint’s original Fill color with stencil paint. This option will not 
be available unless you have an image or movie loaded in the Stencil layer. 

5. Click OK.
The paint on the clipboard will be pasted to the frames you specified.



Paste Special
The Paste Special command allows you to specify special conditions when pasting the contents of the clipboard in 
the active document window. The top two options in the Paste Special pop-down menu, Paste New From Last and 
Paste All From Last, allow you to paste New and All paint from one frame to another. The last three commands, 
Paste Film Color As None, Paste Luminous As Opacity, and Paste Luminous As Transparency, are used primarily 
when creating custom brushes (see the chapter on Advanced Features for details on making your own gradient 
brushes).

Paste New From Last
This option will paste all new paint from the last frame you painted to the current frame. “Last” does not refer to 
the frame directly before the current frame. Rather, it refers to the last frame you painted on. Paint does not need 
to be selected for this option, but remember that only new paint is copied (please refer to the Auto Copy 
discussion in Chapter 3 for descriptions of old and new paint).

Paste All From Last
This option will paste a copy of all the paint on the last frame you painted or worked on. For example, if you 
painted on frame one and jumped forward to frame three without taking any action in frame two, the Pasted All 
From Last option would place a copy of all paint from frame one to frame three. However, if you stepped forward 
to frame two and performed an action such as laying down paint, selecting existing paint, or simply using the 
magnify tool, all the paint from frame two will be copied to frame three when the Paste All From Last command is 
selected. Remember, “last” always means the last frame you took action in.

Paste Film Color As None
This command will compare any paint on the clipboard with the current Film color. Any paint that matches the 
color of the film will be removed when pasted.
For example, with a movie in the Movie layer, a rectangle can be drawn using white as the Fill color, blue as the 
Line color, and white as the Film color.

When the paint is selected, cut, and pasted with the Paste Film Color As None command, the white Fill paint is 
removed because it matches the Film color.

Paste Luminance As Opacity
Luminance is the amount of light radiated from the monitor. White paint is the most luminous, while black paint is 
the least luminous. The lighter the color, the more opaque it will become when it is pasted using this option. 
Darker colors become more transparent. This is achieved by increasing the level of alpha in brighter colors, and 
decreasing the alpha in darker colors.
White paint will appear completely opaque. Black paint will become completely transparent.

Paste Luminance As Transparency
This option will give the opposite results of Paste Luminance As Opacity. In this case, darker colors become more 
opaque while lighter colors become more transparent.
Black will become completely opaque and white paint will become completely transparent. All colors in between 
will receive a gradient level of transparency according to the degree of luminosity of the color.



Duplicate
The Duplicate command is similar to performing the Copy and Paste commands in one operation, but nothing is 
placed on the clipboard. To use this function, select an area of paint and choose Duplicate from the Edit menu. 
The paint will be duplicated directly on top of the selected paint, and the new paint will become the selected 
paint. Before deselecting the new paint you may want to move it to another location in the current frame or step 
forward or step backward to another frame to place the paint. 
When working within a single frame, the Duplicate command is identical to an Alt-drag, which leaves a copy of the
paint behind.
When working with multiple frames, the Duplicate command will place the new paint in the same location as the 
selected paint. This is quite useful when copying paint from frame to frame.
The Duplicate command differs from the Copy and Paste commands only in regards to where the selection is 
placed in the window.
The Paste command will center the selection on the point where the left mouse button was last depressed, which 
may not be the same location as the original object. The Duplicate command will always place the selection in the
exact grid location as the original, even when the image is carried from frame to frame.



Using the Auto Copy option
There are times you will want to copy paint to multiple frames. You can instruct MediaPaint to automatically copy 
paint from frame to frame by using the Auto Copy options.
You can enable Auto Copy by choosing one of the options from the Auto Copy pop-up menu in the Movie Controls 
palette, or by choosing one of the Auto Copy options from the Movie menu.

Auto Copy New
Auto Copy New copies only new paint from the current frame and applies the copied paint to frames as you 
advance to them using the step forward button on the Movie Control palette, the right arrow key on the keyboard, 
or the record button. 
Old paint is not copied (for more information on new and old paint and the Auto Copy function, please refer to the 
discussion in Chapter 3).

Using Auto Copy New
You must select Auto Copy New before leaving the beginning frame. It is also important you use only the Step 
Forward or Record buttons for Auto Copy. Pressing the Rewind button on the Movie Controls palette will turn Auto
Copy off.
1. Draw a red rectangle on the left side of the active document window.
Make sure the active window is the first frame of the filmstrip (frame 1).
2. Step to the next frame (frame 2) and draw a blue rectangle at the top of the window.
Auto Copy should still be turned off at this point.
3. Step Backward to frame 1 and draw a yellow “X.”
Use a standard brush from the Dots palette to draw a freehand letter    X” in the bottom corner of the red 
rectangle.
The colors indicated in this example are completely arbitrary. You may use any colors you like.
4. Turn Auto Copy New on and step forward one frame.
You can choose Auto Copy New from the Movie Controls pop-up palette or select it from the Movie menu. Just be 
sure you turn the option on before stepping to the next frame or nothing will be copied.
You will notice the yellow “X” is the only object that was copied to the frame. This is because the red rectangle 
became old paint when you stepped back to frame 1.
Click on the Rewind button to turn Auto Copy off (or any button other than step forward). If you wanted to 
continue to copy the “X” onto other frames, you could do so by clicking on the Step Forward button.
Auto Copy All

Auto Copy All copies all paint on the current frame and applies it to the frame you are moving to. It does not 
matter if the paint is old or new. Everything will be copied to the next frame using this option.

Using Auto Copy All
1. Draw a red rectangle on the left side of the active window.

Make sure you are on frame 1 of the filmstrip.
2. Advance to the next frame and draw a blue rectangle at the top of the document window.

Auto Copy should still be turned off for this operation.
3. Step Backward to frame 1 and turn on Auto Copy All.
4. Paint a yellow “X” in the bottom corner of the red rectangle.

It is not important whether you turn Auto Copy All on before or after you add the paint.
5. Step forward to frame 2.

This time the “X” and the red rectangle will be copied to the next frame and placed on top of the blue 
rectangle.
You can choose whether to Auto Copy stencil paint above or below other paint being copied forward with the 
Stencil Paint command in the Movie menu. For more information on this function please refer to the Stencil 
Composite Mode section in the Advanced Features chapter of this manual.
Turn off the Auto Copy option by choosing Auto Copy Off from the Movie menu or from the Movie Controls 
palette pop-up menu.



Selecting a range of frames
You can select a range of frames by clicking on a frame in the Filmstrip, holding down the Shift key, and clicking on
a frame at the other end of the selection. All intermediate frames will be included in the selection. All selected 
frames will be displayed with a black-and-white selection border. 

Using the Select Frames command
You can also choose the Select Frames command from the Edit menu to specify a range of frames to work with. 
When the command is chosen, the Select Frames dialog will be displayed from which you can set the parameters 
of your selection.

All Frames
Selecting this option will select all frames in the document.

Relative Range
This option allows you to specify how many frames will be selected previous to, or forward from, the current 
frame. It is important to note that the current frame will always be included in the total number of frames 
selected. Therefore, if you enter “2” in the Previous box, the current frame and one previous frame will be 
selected. Values in the Relative Range box may also be entered in the Time Code format.

Absolute Range
Enter the beginning and ending frame numbers, or Time Code locations, of the frames to be selected. The 
currently selected frame does not have to be in the range you select.



Inserting and deleting frames
You can insert blank frames or delete frames of paint from your document. However, it is important you remember
that inserting or deleting frames only affects the Paint layer. The Movie and Stencil layers are not changed by this 
operation. For that reason, you should use caution not to insert or delete painted frames within a completed or 
partially completed project. Doing so could alter the Paint layer’s synchronous playback with other layers.

Inserting frames
To insert frames in your filmstrip, choose Insert Frames from the Edit menu. Use the dialog box pop-up menu to 
change the format to Frames or Time Code and enter the appropriate number of frames to insert.

Frames
Simply enter the number of frames you want to insert. The new frames will be inserted in front of the selected 
frame.

Time Code
Enter the number of frames you want to insert in Time Code format. For example, if you enter 00.00.01:00, one 
second’s worth of frames will be added. If the frame rate is set to 15 frames per second, 15 frames will be added. 
Blank frames will be inserted in front of the selected frame in your filmstrip.
You may add only empty paint frames to your project. You cannot add frames to the Movie or Stencil layers. Also, 
inserting frames will not increase the duration of your project. If you want to add frames to the end of your movie, 
slide the Out Point on the filmstrip to the right.

Deleting frames
Select Delete Frames from the Edit menu to delete frames from the filmstrip. The Delete Frames dialog box will 
allow you to choose to delete frames in one of four ways:

All Frames
Selecting this option will delete all frames of paint from the Paint layer. 

Selected Frames
All selected paint frames in the Filmstrip will be deleted. You may select a range of frames by clicking on the first 
frame you want to select, and while holding the Shift key down, clicking on the last frame you want to include. All 
frames between the two will be included in the selection.

Relative Range
This option allows you to specify how many frames will be deleted previous to or following the currently selected 
frame. It is important to note that the current frame will always be included in the total number of frames deleted.
Therefore, if you enter “2” in the Previous box, the current frame and one previous frame will be deleted. Values in
the Relative Range box may also be entered in the Time Code format.

Absolute Range
Enter the beginning and ending frame numbers or Time Code locations of the frames to be deleted. The currently 
selected frame does not have to be included in the range to be deleted.
As with the Insert Frames command, you may delete only Paint layer frames. You may not delete frames from the 
Movie or Stencil layers. Deleting frames does not decrease the overall duration of your project. An equivalent 
number of adjacent frames to the Out point will be added to your project whether they contain paint or not. If you 
want to decrease the duration of your project, slide the Out point on the filmstrip to the left.
You may also delete frames by selecting a frame or range of frames on the filmstrip and pressing the Backspace 
key, or select Clear from the Edit menu. All selected frames will be deleted.
You can delete the paint from all of the frames in your document by activating the filmstrip and holding down the 
Control key while pressing the Backspace key. This procedure works as a combination of the Select All and Clear 
commands.



Reversing the order of the frames
There may be times when you want to reverse the order of the frames in your document. To change the order, 
select the frames you want to reverse and choose Reverse Frames from the Edit menu. The selected frames will 
be rearranged in reverse order. You should note that reversing frames only affects the Paint layer. The Movie and 
Stencil layers will not be affected.



Clear Movie
Use the Clear Movie command from the Edit menu to remove the current movie from the document’s Movie layer. 
Importing a new movie into the Movie layer will also clear the current movie. Only one movie can be loaded in the 
Movie layer at a time.



Clear Stencil
This command will remove the currently loaded stencil from the Stencil layer. Clear Stencil can be selected from 
the Edit menu. 
As with the Movie layer, only one stencil can be present on the Stencil layer at a time. Therefore, importing a new 
stencil will also clear the current stencil.



Clear
Selecting the Clear command from the Edit menu has the same effect as the Backspace key. To simultaneously 
Select All and Clear, hold down the Ctrl key while pressing the Backspace key.
If the document window is active, all paint in the current frame will be cleared. If the filmstrip is active, the paint 
from every frame in the filmstrip is cleared when using this method.



Undo
Select Undo from the Edit menu to undo your last move. In most cases, MediaPaint will warn you when you are 
about to perform a function that cannot be undone, such as recording paint while a video is playing or filtering 
multiple frames.
Deleting colors, brushes, patterns, etc., however, cannot be undone even though you are not warned prior to 
deletion.



Chapter 5
Process Filters

Introduction
The process filters in MediaPaint provide a powerful means of creating special photographic effects globally on 
your project. The filters included with the software package represent some of the most asked for and widely used
types currently on the market. There are also a couple of special filters you may not have seen before.
In addition to the filters shipped with MediaPaint, many third party plug-in filters can also be used. This gives you 
the ability to easily upgrade your overall package and expand your special effects capabilities.
The Process filters work much like the various plug-in tools available in MediaPaint except the filters’ effects are on
a global scale rather than affecting only pixels the tool is dragged over. Many of the filters are also tweenable, 
which means their effects can be spread gradually over time.
Tweening is the process of making a smooth transition from one point to another over time. In the case of Process 
Filters, the software will compare the selected object in its original form with the way that object will look at the 
end of the transformation. Adjustments to the object are then spread evenly across the number of frames you 
have specified for the transformation to occur. When the frames are played back, the tweening results in a 
smooth, gradual change from the original object to the fully transformed object.
You can choose the Undo command from the Edit menu immediately after applying a filter to cancel the effect. 
Also, once a filter has been used it will appear in the special menu box at the top of the Process pull-down menu. 
You can use the Ctrl + F keyboard shortcut to apply that filter again. This special feature allows you to apply the 
last-used filter with a keystroke.



Tweenable filters
Forcing a filter to apply its effects over time is known as tweening. All tweenable filters shipped with MediaPaint 
can be identified in the Process menu by three periods following the name of the filter.
To apply a filter effect over a range of frames you must have the Filmstrip active.

Tweening a filter
1. Select the area to be affected by the filter.
Draw a marquee around the area from the active document window to which you want to apply the filter effect. 
Not selecting anything in the window or choosing Select All will apply the effect to the entire document window.
2. Click on the Filmstrip to make it active.
The Filmstrip must be active to apply a filter over time.
3. Select the range of frames to be affected.
To select the frame range, hold the Shift key down while clicking on the first and last frame you want affected. 
Select All to select the entire filmstrip.
4. Choose the filter you want to apply from the Process menu.
If you choose a filter that is not tweenable (tweenable filters have three periods after the name), the effect will 
be applied equally to all selected frames. Click Proceed in the warning dialog to continue with the operation.
If the filter is not tweenable, the operation will be processed at this point and applied to all selected frames.
5. Set the filter’s Start and End Values options.
When a tweenable filter is chosen, and multiple frames are selected, that filter’s options dialog will appear with 
two additional radio buttons-the Start Values and End Values buttons. Click the Start Values button and set the 
filter’s options to create the effect you want in the first selected frame. Then, click on the End Values radio 
button and set the options again, this time to reflect how the image will look in the last selected frame when the 
filter effect is complete. You can set the start and end values in reverse order if you wish. Click OK to apply the 
filter effect to the selected range of frames.
You can apply a tweenable filter to a single frame as well. When the filter is applied to a single frame, the setting
options dialog will appear without the Start and End Values radio buttons. 



Set Channels
The Set Channels command, located in the Process menu, is important to all the Process filters because the 
settings in this dialog affect how each filter looks at pixels. You need to understand how it works before using any 
of the filters.
You will notice the checkboxes correspond to the standard RGB (Red, Green, and Blue) color channels. There is 
also a checkbox for the Alpha channel and another labeled Clip. Each of the checkboxes in the Set Channel dialog 
will be turned on by default, which means filters will affect all channels. Turning any of the checkboxes off will 
prevent the filters from altering those channels.
You should note that a single pixel can contain elements from every channel. Therefore, turning off the Red 
channel, for example, will only affect those elements of the pixel that fall into the Red channel parameters.
· The RGB channels affect actual colors in the object.
· The Alpha channel deals with the transparency (or opacity, if you prefer) of paint.
· The Clip channel refers to the area encompassed in the marching ants selection border.
Turning this checkbox on will allow the filter’s effects to spill over the marquee border. When the Clip checkbox is 
turned off, the filter’s effects are restrained to the area within the marquee.



Blur
The Blur filter averages differences in colors and smoothes those differences to create a blending between 
contrasting colors. This has the effect of softening the edges of differing colors in the area you have selected. To 
blur a selected area, select the area to be blurred and choose Blur under the Process pull-down menu. The area is 
automatically blurred.



Blur More
The Blur More filter works the same as the Blur filter, but the amount of blur is increased. To blur more, select an 
area with a marquee tool and choose Blur More under the Process menu.



Brightness-Contrast
As the name suggests, the Brightness-Contrast filter allows you to adjust the levels of color brightness and the 
amount of contrast between light and dark colors.

Setting the Brightness-Contrast options
The Brightness-Contrast options dialog allows you to establish the extent of the filter’s effect on selected paint. 
Each field in the dialog affects the other, so you should make adjustments in small increments until the desired 
effect is achieved.

Brightness
The Brightness slider has a range of -100 to 100 percent. The range will adjust colors to totally black (at -100 
percent) and twice the original brightness (at 100 percent).
The previous illustrations show the effect of the Brightness slider when adjusted to -50 percent and positive 50 
percent.

Contrast
The Contrast slider also has a range of -100 to 100 percent. The amount of contrast is based on middle gray.
As you can see in the previous illustrations, moving the Contrast slider left (toward -100 percent) draws varying 
shades closer to middle gray. Sliding the control to the right (toward positive percentages) pushes varying shades 
farther from the median shade, which produces more stark differences between shades.

Preview
Click the Preview button to view the effect of your settings prior to committing to the operation. Turning on the 
Auto checkbox forces the document window to update automatically as you change the dialog settings.
This filter is tweenable, so the effect can be animated over a range of frames.



Color Gradient
The Color Gradient filter allows you to apply a colorized or grayscale gradient effect to a selected area in the 
active document or filmstrip window. This filter does not directly affect paint already placed in the active window. 
Rather, it applies new paint to the area outlined by one of the selection tools. However, if existing paint lies within 
the selection boundaries, it will be covered when the gradient is applied.
If you want to apply a gradient to existing paint, which will change the color of that paint, you must select the 
paint and turn off the Alpha channel before applying the gradient. Use the Set Channels dialog in the Process 
menu to toggle the Alpha channel on and off.
The colors used for the gradient fill are established by the currently selected fill and film colors. The direction of 
the gradient fill is determined by the Angle setting in the filter dialog.

Setting the Color Gradient options
The Color Gradient options dialog allows you set the angle of the gradient effect and whether it will be mirrored.

Angle
The Angle slider establishes the number of degrees the gradation effect is rotated. At a setting of zero, the 
gradient effect lines up horizontally.
The preceding illustration demonstrates how the selected fill color is applied to the far left of the selected area 
when the Angle field is set to zero degrees. The current film color is applied to the far right and the area between 
is filled with smooth transitions between the two base colors.
The Angle field follows a clockwise rotation. Thus, a setting of 90 degrees would set the fill color at the top of the 
selected area and the film color at the bottom and so on.

Mirror
Check the Mirror checkbox to enable the mirror effect. When the Mirror option is active, the film color will be used 
at the selected area’s center. The fill color will be set at each end of the selection.
In the preceding illustration, the Angle field was set to zero degrees with the mirroring option turned on. Notice 
how the gradation effect proceeds from the fill color on the far left to the film color in the center then back to the 
fill color on the far right.

Preview
Click the Preview button to view the effect of your settings prior to committing to the operation. Enabling the Auto 
checkbox forces the document window to update automatically as you change the dialog settings.
This filter is tweenable, so the effect can be animated over a range of frames.



Diffuse
Use this filter to displace pixels within the area you have selected. This causes the paint to appear fuzzy or 
randomized. To diffuse an area selected with a marquee tool, choose Diffuse under the Process menu and the area
will automatically be diffused.



Diffuse More
The Diffuse More filter works the same as the Diffuse filter except the pixels in the selected area are displaced 
farther. To diffuse more, select an area with a marquee tool and choose Diffuse More under the Process menu.



Diffuse Custom
The Diffuse Custom filter is the same as the Diffuse filter except that it allows you to select the spread of the 
selected area. To do this, select the area with a marquee tool and choose Diffuse Custom under the Process menu.
When the dialog box appears, choose the maximum distance each pixel can be moved with the Spread slider 
control and click OK. You can turn on the Preview option to view the effect before committing.

Spread
Spread determines how far a single pixel can be displaced. The Diffuse Custom filter then randomly moves pixels 
up to the maximum set in the Spread field. The range of displacement can be set from 1-32 pixels.
This filter is tweenable, so the effect can be animated over a range of frames.



Dotlet
The Dotlet filter lets you transform selected paint pixel by pixel to create special graphic effects that add flair to 
your project.
This filter laces selected objects with graphically pleasing lines and shapes by drawing lines and shapes using 
various colors it samples from the selection as fill colors.

Setting the Dotlet options
The Dotlet options dialog allows you to control how the filter will affect the selected paint. The settings in the 
dialog alter the overall effect, so you should make yourself familiar with how each works.

Line/Shape selector buttons
These radio buttons, located in the upper left side of the dialog box, let you choose whether to have lines, shapes, 
or both in the effect. Only one can be turned on at a time.

Density
The Density setting controls the percentage of pixels in the selected paint that will be transformed by the Dotlets 
operation. At a setting of 50 percent, half the painted pixels in the selection area will become dotlets. All the pixels
will be transformed if you raise the setting to 100 percent.

Colors
The Colors field lets you vary the colors used for the dotlets. The Dotlets filter samples colors in the pixel that will 
be transformed and applies variations of those colors to the dotlet. How varied the colors are depends on the 
Colors setting. A setting of zero in this field will create the same color dotlet as the original paint. Increasing the 
setting allows the filter to randomly select colors along the RGB scale.
For example, setting the Colors field to ten allows the filter to vary the colors plus or minus ten RGB color units 
from the original color. The maximum setting in the field is 64.

Lines
The lines dialog allows you to set the parameters of lines used in the Dotlets operation.

Length
The Length setting establishes the maximum pixel length of the lines used in the Dotlet operation. If the Vary field 
is set to zero, the Length setting will establish the actual length of all lines except those clipped by the marquee 
border.

Vary
This field lets you apply varying lengths of the Dotlet lines. The variations use the Length setting as the control 
length. That length is then randomly varied plus or minus the number entered in the Vary field.
For example, if the Line Length is set at 10 and the Vary is set at 2, the lines can vary in length from eight pixels 
long to 12 pixels long.

Angle
Use of the seven Angle radio buttons is fairly straightforward. Turning on an option creates lines corresponding to 
the setting.
· 0° produces all horizontal lines.
· 45° produces lines tilted 45 degrees to the right of vertical.
· 90° produces all vertical lines.
· 135° produces lines tilted 45 degree to the left of vertical.
· 0°/90° produces a combination of horizontal and vertical lines.
· 45°/135° produces a combination of tilted lines.
· Mixed produces a combination of all the angle line options.

Shapes
The Shapes dialog allows you to set the parameters of the shapes used in the Dotlet operation.
You can choose to use Squares, Circles, or both in the Dotlet operation with the radio buttons at the top of the 
dialog.

Width



The Width field, as the name implies, sets the width in pixels of the shapes used in the Dotlets operation. This field
applies to both squares and circles.

Vary
This setting allows the width of shapes to vary from the Width setting by plus or minus the number in the Vary 
field.

Height
The Height field sets the vertical measure, in pixels, of the shapes. This field applies to both squares and circles.

Vary
This setting allows the height of shapes to vary from the Height setting by plus or minus the number in the Vary 
field.

Presets
Choose the Presets button to return the dialog to default settings.

Preview
Click the Preview button to view your settings prior to committing to the operation. Turning on the Preview 
checkbox forces the document window to update as you change the dialog settings.
This filter is tweenable, so the effect can be animated over a range of frames.



Fade Edges
As the name implies, this filter fades the edges of paint objects in the selected area. This is done by lowering the 
alpha of the paint along the paint’s edges, which increases the transparency of the paint in the affected pixels.
To use the filter, simply select an area in the active window or select all and choose the Fade Edges filter from the 
Process pull-down menu.



Fade In
This filter increases the opacity of the selected paint by raising the alpha level of that paint.
The maximum setting in the Fade In filter’s dialog is 300 percent. If the object selected is already at full opacity, 
using this filter will have no effect.
This filter is tweenable, so the effect can be animated over a range of frames.



Fade Out
The Fade Out filter has the opposite effect of the Fade In filter in that it reduces the alpha level of the selected 
paint, thereby increasing the transparency of that paint. The Fade slider allows you to set a range from 0-100 
percent.
This filter is tweenable, so the effect can be animated over a range of frames.



Falloff
This filter expands the edges of selected paint to create a feathered look. To use this filter, simply select the paint 
you want affected and choose the Falloff filter from the Process menu. Move the slider bar in the dialog to set the 
amount of falloff you want (checking the Preview box will update your active window as you move the slider).
You may want to set the selection tool modifier to No Shrink when selecting the paint for this process. If the Shrink
mode is used, the marquee border could inhibit the feathering effect of the filter.
This filter is tweenable, so the effect can be animated over a range of frames.



Fill
This filter fills all pixels in the selection with the currently selected fill color. Simply choose a Fill color from the 
Color palette, select the area to be filled with the marquee tool, and choose Fill from the Process pull-down menu. 
The area will be filled with the new color without altering the alpha to preserve smooth edges.



Hue-Saturation
The Hue - Saturation filter provides a means of differencing colors in a selection. This differencing has the effect of
changing the color of various components in the image and establishes their relative brightness. This simplistic 
explanation will be discussed further in each of the filter’s topics.

Setting the Hue-Saturation options
The Hue - Saturation options dialog allows you to fine tune the colors and brightness of an image using the HSL 
color space. This is done through three slider controls affecting the Hue, Saturation, and Luminance levels in the 
selected paint.

Hue 
The Hue slider controls color. Moving the slider to the left or right of center reorients color components around the 
standard color wheel. In effect, the coloration of any given color component is determined by its position on the 
color wheel. The Hue slider rotates those positions on the wheel, giving each component a new color assignment.
The previous illustration demonstrates how the coloration assigned to a single color component is changed from 
red to green when the Hue slider shifts that component’s orientation on the color wheel by 90 degrees. Other 
color components would also be assigned a new coloration based on where on the color wheel the 90 degree 
rotation left them.
You should note that, by default, all components would be rotated the same number of degrees on the color 
wheel. However, you can control which color components are rotated through settings in the Process menu’s Set 
Channels dialog. By turning specific colors on or off in the Set Channels dialog, the Hue slider’s effect can be 
limited to a specific range of colors. If all colors are turned on in the Set Channels dialog, which is the default 
setting, the Hue slider will rotate all color components equally.

Saturation
The Saturation slider controls the relative purity of colors. Moving the slider to the left (into the negative numbers)
decreases the purity, washing colors out toward their grayscale values. Moving the slider into the positive 
numbers increases the saturation, or purity, of colors by adjusting each toward its primary color.
The previous illustration shows how the Saturation slider can shift a color component’s position inward or outward 
on the color wheel. In effect, the Saturation slider controls the radius of the Hue slider’s rotation.
Images can be fine tuned using the Hue and Saturation sliders. Just remember, the Hue slider rotates color 
components around a fixed point at a constant distance from that center point. The Saturation slider controls the 
distance from the center point. For the mathematically minded, Hue moves components around the circumference
of a circle while Saturation establishes the radius of that circle.

Luminance
The Luminance slider controls how much light is reflected from each color, thus affecting the relative brightness of
the selected image. This slider adjusts from black at the leftmost position to white at the rightmost position.

Preview
Click the Preview button to view the effect of your settings prior to committing to the operation. Turning on the 
Auto checkbox forces the document window to update automatically as you change the dialog settings.
This filter is tweenable, so the effect can be animated over a range of frames.



Invert
The Invert filter changes the color of the paint in the selected area to the opposite color on the RGB color wheel. 
For example, if the original paint color in the selected area is blue, the Invert filter will change that paint to yellow. 
Reapplying the Invert filter to the same area will change the color back to blue.
Obviously, most selections will contain numerous colors and color variations. The filter looks at all pixels in the 
selected area and changes each.



Lens
The Lens filter provides a means of creating an optical distortion of a selected image. This distortion can make it 
appear as though the selected image is being viewed through a fish bowl or create the illusion the image is being 
drawn toward a single point at the center of the selection. You can apply the Lens filter effect to paint on the Paint 
layer or, by switching the Layer Mode selector to Movie, you can apply the effect to a copy of the imported movie 
(please refer to Chapter 3 in the MediaPaint manual for more information on copying images from the Movie layer 
to the Paint layer). You can choose whether the effect will be applied to the entire document window or to a 
specific portion by drawing a selection marquee around the area you want affected.

Setting the Lens options
The Lens options dialog allows you to establish how the filter will affect selected paint. You can adjust the fields to 
suit your needs or use one of the preset settings to create the desired effect.

Distort
The Distort slider controls the extent and type of distortion that will be applied to the image. Moving the slider to 
the left (negative numbers) creates a concave effect by demagnifying the center point of the selection (making 
the center point smaller) by the number set in the Distort field. The outermost points of the selection remain at 
their original size and points lying between are proportionally sized to create the concave effect. The maximum 
demagnification is -1000, or 10 times smaller than the original size.
Moving the slider to the right (positive numbers) creates a convex effect using the same principle applied in 
reverse. That is, the center of the selected area is magnified by the number set in the Distort field. Again, the 
outermost perimeter of the selection remains at actual size and points in between are proportionally adjusted to 
create a convex effect. The maximum magnification is 1000, or 10 times the normal size.

Shading
The Shading slider adjusts the intensity of shadow applied to the selected image. The shading simulates the effect
of placing a light source above and to the left of the selected image. When this slider is set to zero, no shading is 
applied to the distorted image. Increasing the amount of shading intensifies the contrast between the areas 
receiving direct light and those blocked from the light by the distortion bubble. Graduating levels of contrast are 
then applied between the lightest and darkest points of the image. When the Shading slider is set to 100 percent, 
the lightest point will be white and the darkest point will be black.

The previous illustration demonstrates how light and dark points vary depending on the Distort setting. When the 
Distort field is set to a positive number to create a convex effect, the area receiving direct lighting will be the top, 
left quadrant of the image. That same quadrant will be in shadow when the Distort field is set to a negative 
number, which creates a concave effect.

Presets
The Presets submenu lets you select from a list of premade settings designed to simulate common photographic 
lens characteristics such as a fish eye and Macro camera lens.

Preview
Click the Preview button to view the effect of your settings prior to committing to the operation.
This filter is tweenable, so the effect can be animated over a range of frames.



Mosaic
The Mosaic filter alters paint to create randomly placed rectangles in the selected area. This effect is similar to 
that used to mask the faces of people so their features are disguised, making them unrecognizable.
Setting the Mosaic options

Square
Turning on the Square radio button activates the Square dialog, which lets you set the size, in pixels, of the 
squares used in the Mosaic filter’s operation. A setting of one in this field will leave the selected paint as it 
originally appeared. The maximum size is 256.

Rectangle
With the Rectangle radio button selected, you can control both the height and width, in pixels, of the rectangles 
used in the mosaic design. The maximum settings in these fields is 256.

Preview
Turn the Preview checkbox on to force the screen to update changes before you commit to the operation.
This filter is tweenable, so the effect can be animated over a range of frames.



Sharpen
The Sharpen filter hardens the detail of the paint in the selected area. The filter eliminates gradient colors along 
the edges of paint, bringing out details and making the edges appear sharper.



Sharpen More
Sharpen More works the same as the Sharpen filter except that the effect is enhanced to bring out even more 
detail in a single application.



Swirl
The Swirl filter, as you may have guessed, swirls an image around a central point located at the selected paint’s 
center of mass to create an effect similar to water being sucked down a drain. This is done by rotating the 
orientation of the image’s center point by the number of degrees indicated by the Angle slider. Pixels along the 
outer perimeter of the selection remain in their original positions and the positions of those in between are 
proportionally rotated to create a vortex effect.

Setting the Swirl options
The Swirl options dialog allows you to establish the intensity of the swirl on the selected paint and whether 
shading will be applied. You can adjust the fields to suit your needs or use one of the preset Swirl settings.

Angle
The Angle slider controls the intensity of the swirl effect. At the maximum setting of plus or minus 3600 degrees, 
the center point of the selection is rotated ten times.
As the previous illustration demonstrates, moving the slider to the left (negative numbers) creates a clockwise 
rotation while slider movement to the right (positive numbers) creates a counter-clockwise rotation.

Shading
The Shading slider adjusts the intensity of the shadow applied to the center of the Swirl vortex as well as the 
lightening effect to the outer peripheries. Simply, the Shading field places a global light source at the mouth of the
Swirl vortex. 
Increasing the amount of shading lightens the areas at the outer edge while creating an increasingly darker 
shadow at the center of the vortex. The illustration shows how increasing the shading can create a black hole-like 
effect on the selection.

Presets
The Presets submenu lets you select from a list of premade settings.

Preview
Click the Preview button to view the effect of your settings prior to committing to the operation.
This filter is tweenable, so the effect can be animated over a range of frames.



Wave
The Wave filter alters an image to make it appear as though it were floating on a rough sea.
The actual effect is more along the line of sound waves: the image is altered by the wave’s frequency and 
amplitude modulations to create a series of wavy patterns.



Setting the Wave options

Frequency
The Frequency, or number of cycles applied to a selected area, can also be measured by counting the peaks and 
valleys in the final object. The higher you make this setting, the more peaks and valleys will be in the object, and 
the closer together the waves will appear.

Amplitude
The Amplitude setting affects the depth of the peaks and valleys created by the Wave filter. The higher the 
setting, the deeper the peaks and valleys.
The Wave filter will extend the selection marquee to hold the final image. The image will not be clipped at the 
marquee.
This filter is tweenable, so the effect can be animated over a range of frames.



Alien Filters
Alien filters are those produced by third party developers. MediaPaint will support many such filters.
To use third party filters, create a folder named Aliens and place it in MediaPaint’s Filters folder. 
Place the third party filters in the Alien folder and launch the application. The filters will appear in the Alien Filters 
pop-out menu.
You can use a shortcut for the Aliens folder to conserve disk space. To use this method, place the folder containing
the third party filters anywhere on your hard disk drive and create a shortcut by highlighting    the folder, then 
clicking with your right mouse button.    Select “Create shortcut” from the menu that appears. Rename the 
shortcut to “Aliens.”
Place the “Aliens” shortcut in MediaPaint’s Filters folder (you must erase “Shortcut to” from the folder’s name once
it is inside the Filters folder).



Stencil Composite Mode
The Stencil Composite Mode affects how stencil paint is copied from frame to frame when the Auto Copy New 
option is turned on. The options are to place the stencil paint below or above standard paint on the Paint layer. You
should note that even though the stencil paint will appear behind or in front of other paint, it is still on the Paint 
layer.
For example, if you lay down a color and then paint over all or part of the color with stencil paint, coupling the 
Stencil Paint Above/Below with the Auto Copy feature allows you to change the position of the stencil paint as you 
step forward. You can toggle the stencil’s position from Above to Below and vice versa as you step forward with 
Auto Copy turned on. In other words, you could place the stencil paint above in one frame and below on the next 
by simply changing the Stencil Paint setting prior to stepping to the next frame.
Again, the Stencil Composite Mode is only available when using the Auto Copy function to copy stencil forward 
through the filmstrip. The stencil paint must be new paint for this function to work because, as has been noted in 
previous discussions, once you return to a frame, all paint is old paint. You should also note the operation will not 
place stencil paint below existing paint (old paint) as you step forward. The stencil paint can only be moved above
or below paint being carried forward with the Auto Copy All and Auto Copy New options.

Using the Stencil Composite Mode
Before you begin this example, you should create a new document with no movie in the Movie layer. Make sure 
you Import a file into the Stencil layer, however, or the following example will not work.
1. Draw an object in the active window using a standard color from the Color palette.
Use any RGB color to draw the object.
2. Draw a second object using stencil paint.
Place this stencil paint object so it slightly overlaps a portion of the first object.
3. Draw a third object with standard color.
Draw this third object using a standard color, different from the first. Again, place it so it slightly overlaps both 
the first and second objects you drew.
You should now have three objects drawn, with the stencil paint object sandwiched between layers of standard 
paint.
4. Choose Above from the Stencil Paint submenu in the Movie menu.
This will place the stencil paint on top of the other two paints when you advance forward with Auto Copy turned 
on.
5. Turn on Auto Copy New and step forward a single frame.
When the new frame redraws you will see the stencil painted object on top of the other two paints brought 
forward.
6. Now change the Stencil Paint setting to Below and step forward.
Changing the setting should place the stencil painted object under the other two objects when you step forward.
The Stencil Paint Above/Below options work the same when stepping forward with both the Auto Copy New and 
Auto Copy All operations. You should note that stencil paint sandwiched between standard paint must be placed 
on top of or behind standard paint objects copied forward using the Auto Copy functions. You cannot step 
forward in this manner and keep the stencil paint sandwiched between standard paints.
You can keep the stencil paint object sandwiched between standard paint if you use the copy/paste function or 
step forward while holding the Alt key, which leaves a copy behind as you step forward. However, these methods
do not allow the stencil paint to automatically update as you step forward.



Gradient brushes
MediaPaint provides an easy way to create brushes that add a special flair to your work. These brushes are made 
from varying patches of grayscaled paint linked tightly together to form a pattern of graduated colors that can be 
likened to a comet streaking across the sky. These specialty brushes are called gradient brushes.
As with all brushes used in MediaPaint, you can save gradient brushes to an existing brush palette or create a new
palette to store your custom brushes. For more information on saving brushes and creating palettes, please refer 
to the chapter on palettes in this manual.

Creating a gradient brush
1. Set the background color.
To ensure you can see the grayscale patches of paint you will use for the gradient brush, change the background
color of the window to a medium grade color such as blue or green. To set the background color, simply hold 
down the Shift key and click on a color in the Color palette.
2. Select a brush from the active brush palette.
You can select any brush or combination of brushes to build your gradient brush, but fuzzy brushes (those with 
soft edges) often create the smoothest transitions.
For this example, choose a large, soft-edged brush from the Dots brush palette. The last brush on the palette 
would be good.
3. Set the Fill color to black and paint the first patch of the gradient brush.
Click on the black patch of the Color palette to set the fill color to black and paint a single dot in the active 
window.
4. Change the fill color to the next darkest shade of gray.
Click on the darkest shade of gray in the color palette. If you are using the Tints and Shades Color palette, the 
darkest gray is in the left, bottom corner of the rightmost block of colors.
5. Paint a second patch of gray in the window.
Make sure you overlap the first dot of black paint enough to create a tight pattern between the two brush 
strokes.
6. Select the next grayscale patch and paint a third dot in the window.
Overlap the second dot with the third in the same manner you did with the first and second dots of paint.
Repeat this process until you have reached white.
7. Select all the painted dots in the window.
Use the Select All command from the Edit menu or use the marquee tool with shrink mode turned on to select all
the dots.
8. Create a new brush palette to store your gradient brush.
You can simply add the gradient brush to the currently active brush palette, but you should create a new palette 
for easier access to your specialty brushes.
With the new palette open, choose the New Brush option from the palette’s Command pop-up menu. The 
gradient brush will appear in the new palette.
9. Delete the painted dots from the active window.
Now that the gradient brush is stored in the new brush palette, the dots you painted are no longer needed. 
Delete them from the window.
10. Select the new gradient brush from the palette.
With the new brush selected, drag a swatch of paint in the document window. If you have not changed the fill 
color from white, which was the color of the last dot you painted as part of the brush, the painted image appears
inverted from the original brush with the black on the opposite side of the brush stroke. This is the correct 
behavior.
You can use any colors with a gradient brush just as you would with a standard brush. The difference is the 
ability to make transitions from one color to another along the brush’s stroke.
The black portions of the gradient brush paint with the selected Fill color. The Film color is used in the white 
portions. Varying shades of gray form the basis for transitions between the colors.
Try setting the Fill color to red and the Film color to Blue. When you paint a stroke you will notice the color of the 
original brush’s black dot will be the same red as the Fill color. The white dot will be blue.
The colors are mixed in varying amounts along the stroke’s path according to the shades of gray to make a 
smooth transition between the two colors.
For a unique effect, try making the Film color an eraser. To see this effect you must first lay down a layer of paint 
that can be erased as the brush is dragged across it.
Using eraser paint
1. In the active window, draw an oval with the Fill color set to yellow.
To fully illustrate this feature, you should set the background color of the active window to a color that will stand 



out. A light green should work well. Then, set the Fill color to yellow and draw an oval with the Oval tool. You can 
locate the oval anywhere in the window. Just make sure it is large enough to fit the entire gradient brush inside.
2. Select the gradient brush you created in the last example and select the colors for the brush.
For this example, set the Fill color to red and select the eraser for the Film color. Make sure the Film color pattern 
selector is set to solid.
When you paint with the brush with these selections, the original white areas of the brush will actually erase any 
existing paint on the Paint layer as that portion of the brush passes over the paint.
3. Drag a paint stroke in the active window so it passes over the oval.
Notice how the light green background color shows through the light areas of the gradient brush stroke where it 
passes over the yellow oval. This is because the yellow paint has been erased from the Paint layer in those 
areas.
You can build gradient brushes in virtually any shape and any number of gray shades. Eraser paint and stencil 
paint can both be used with gradient brushes as well as standard colors.



Chroma Key
The Chroma Key technique, the same method used in the television and movie industry’s “bluescreen” method of 
masking colors to create transparency, allows you to key selected colors of a movie or image stored in the Stencil 
buffer and adjust the keyed colors to any level of transparency. The new transparencies will be carried over to the 
Paint layer when the stencil is used for the Fill color of your brush or tool. This technique allows images in the 
Movie layer and any paints already applied to the Paint layer to show through the keyed colors of the stencil paint 
when it is applied to the Paint layer.
This feature only applies to stencil paint. Obviously, you must load a file into the Stencil buffer to use the Chroma 
Key feature. You should note that using the Chroma Key feature establishes transparency where none existed 
before by creating an alpha channel based entirely on color information from the image. When Chroma Key is 
active, transparency information saved with the original image is overridden.
Also, you must key the colors for transparency before the stencil paint is applied to the Paint layer.
Adjusting the color key can be done with the slider bar controls or by clicking on the appropriate adjustment 
arrows.
The Chroma Key settings

Information display
The Information display window at the top of the Chroma Key dialog allows you to see the list of currently keyed 
colors and their settings. The display also allows you to select a keyed color to make changes to the settings.

Preview window
The Preview window displays the most current color sampled from the Stencil layer.

Alpha
The ALPHA slider sets the concentration of alpha particles in the selected color. A setting of 100 percent provides 
the highest concentration of particles, making the color opaque. The lower the ALPHA setting, the more 
transparent the color will be.

Softness
The Softness slider establishes how transparency is varied across colors as they fall away from the keyed color. 
The more distant a color is from the keyed color, the more opaque it will become when the stencil paint is applied 
to the Paint layer. A Softness setting of 100 percent will produce a soft, feathered edge between opaque and 
transparent colors. Lower settings can create banding between varying levels of alpha.

Color Tolerance
There are six Color Tolerance sliders that allow you to set positive and negative tolerance levels for each field of 
the currently selected Color mode (HSL or RGB). The left slider affects the negative range of colors (those smaller 
than the keyed color). The right slider affects the positive range of colors (those larger than the keyed color).

Color mode
The Color mode pop-out selector allows you to toggle between HSL (Hue, Saturation, and Luminance) and RGB 
(Red, Green, and Blue) color modes. While most color computer monitors display images in RGB color, you should 
get a more accurate sampling when using the Chroma Key feature in the HSL mode. Using the HSL Color mode in 
the Chroma Key dialog will not affect your monitor’s display.

Add
The ADD button allows you to include the currently selected color sample and its settings to the keyed colors 
listed in the Information display.

Load
The LOAD button allows you to open a previously saved Chroma Key list. To load a list, simply click the LOAD 
button, select the saved file, and click LOAD. The loaded list will appear in the Information display.

Save
Click the SAVE button to save the current Chroma Key list to your hard disk drive.

New
Click the NEW button to clear the current Chroma Key list and begin a new list. You will be asked if you want to 
save the current list before it is closed.



Composite preview
The stencil image displayed in the document window will reflect adjustments you make in the Chroma Key dialog 
when the Composite Preview is turned on. Turning this option off uses less memory and could increase the 
performance speed of your computer while you are making adjustments in the Chroma Key dialog.

Keying colors for transparency
1. With a file loaded in the Stencil buffer, choose the Set Stencil Alpha option from the Layout menu.
When the Stencil Alpha dialog appears, click the Chroma Key radio button to open the Chroma Key dialog. You 
will notice the stencil is displayed in the document window whenever the Chroma Key dialog is active.
You can also access the Chroma Key dialog by choosing the Set Chroma Key command from the Layout menu 
after the Chroma Key feature has been enabled in the Set Stencil Alpha dialog.
The Chroma Key dialog is a floating window, which means you can drag it to any position on the screen if it 
interferes with your view of the document window.
2. The Eyedropper tool will appear when you move the cursor over the document window. Click on a color in
the window. 
The eyedropper, also called the Color Pickup tool, will sample the selected pixel for color. The results will appear 
in the Chroma Key dialog preview window.
3. Adjust the Alpha slider to set the transparency of the color.
The Alpha slider will default to 100 percent (opaque) when a color is selected. Adjusting the slider to less than 
100 percent increases the transparency. The lower the setting, the more transparent the color will become.
4. Adjust the color tolerance levels.
The tolerance sliders for RGB and HSL color modes establish the range of like colors a transparency key will 
affect. Each color has two slider controls to adjust the positive and negative ranges. The sliders default to zero, 
which means only those colors which exactly match the keyed color will be affected.
5. Adjust the Softness slider.
The Softness affects transparency levels as the color falls away from the color tolerance settings. Colors that 
exactly match the keyed color will have the full alpha setting of that keyed color. The farther away a color is from
the keyed color, the more opaque it will become. Obviously, colors falling outside the keyed color’s tolerance 
range will be completely opaque.
The default setting of 100 percent will give a soft, feathered edge to the transparency. Adjusting the Softness to 
less than 100 percent will tighten the transitional range until, at 0 percent, all keyed colors will have the same 
alpha value, leaving a sharp edge where the color changes.
6. Add the sampled color to the Information display list.
Click the ADD button to include the selection in the Information display list. The display will show a sample of the
color, the Alpha setting, the Softness setting, and the Color mode.
7. Select the next color and adjust the settings.
You can add as many color keys as you want. Simply follow the procedure outlined in Steps 1-6 for each color 
you want to key.
You can change the settings of any keyed color listed in the Information display by selecting the key in the 
Information display. Any changes to the selected key color are automatically reflected in the stencil. You can also 
save the current list by clicking the SAVE button. Once a list has been saved, you can use it again in another 
project by clicking on the LOAD button and opening the Chroma Key file.
Once a list of keyed colors has been compiled in the Chroma Key dialog, simply close the dialog by clicking the 
Close box in the upper, left corner of the dialog. When you apply stencil paint to the Paint layer, the keyed 
transparencies will be used.
You do not have to save the Chroma Key list to your hard drive to apply the transparencies to your current 
project. The list will be saved with the current document when it is saved as a MediaPaint file. However, you 
cannot pull an unsaved Chroma Key list from one document to another. If you want to use the list in another 
project, you must save it and load it in the new project.



Slip None
The Slip None feature allows you to exclude specified colors from a selection. When a document is first opened it 
is filled with None paint. While None paint may sound and look like no paint, it is actually a measurable and 
important element in MediaPaint. Without it, the selection tools would not be able to wrap tightly around a 
selected image in the document window.
When used in conjunction with the Film color, the Slip None feature includes the Film color as a None paint. As a 
result, the Marquee and Lasso selection tools will slip over paint that matches the Film color to wrap around a 
different colored image in the selection area.
You must have the selection tool modifier set to one of the Shrink modes and the Film pattern must be set to Solid 
for the Slip None feature to work. When Slip None is turned off from the Layout menu, the Marquee and Lasso 
tools will select all paint within their boundaries, including None paint. Turning Slip None on allows a selection 
tool’s marquee to “slip” over None paint and that which matches the current Film color.

Using the Slip None feature
As was mentioned, you must have the selection tool modifier set to one of the Shrink modes before using the 
Slip None feature to slip over paint matching the Film color.
1. Draw a large, white rectangle in the active window.
Make sure the rectangle’s line color is also set to white.
The color, shape and size of the object you draw can be anything you like. For this discussion, however, simple 
shapes will be used to illustrate the feature’s use.
2. Draw a second, smaller rectangle inside the first.
Make this rectangle red, and ensure the line is set to the same color.
3. Set the Film color to white.
Use the color pickup eyedropper to match the white rectangle. Remember to hold the Alt key while you click on 
the white rectangle to set the Film color to white.
4. Turn the Slip None feature on.
Toggle the Slip None feature on in the Layout menu.
5 . Draw a selection marquee around both rectangles.
Use the Marquee selection tool with the modifier set to Shrink to select the paint.
Make sure you draw your marquee large enough to completely surround both rectangles.
The marquee will “slip” over the white rectangle and shrink around the red rectangle.



Particle tools
While MediaPaint’s standard plug-in tools enhance the overall software package, the special plug-ins called 
Particle tools add a new level of versatility and power to the application.
Particle tools are self-animating, which means they create special effects of their own over time. You control the 
extent of the effect through each of the tool’s dialog settings.
To use any of the Particle tools, simply double click on the tool’s icon to prompt the dialog, choose the settings you
want, turn on record, and paint. The tools will do the rest.
You should note that Particle tools randomize many of the settings in their respective dialogs to produce their 
dynamic effects. Therefore, changing the setting of a particular field establishes the maximum value of that 
characteristic. The particles produced by the tool will vary the from the minimum allowed value of each 
randomized field (generally a nonexistent or non-discernible value) to the maximum you set with the control 
slider.
Each of the Particle tool dialogs have a small Preview window where you can see the results of the dialog settings 
before drawing the image in the document window. Turning the Preview Settings checkbox on allows you to draw 
in the preview window as you would in the document window.
You should note that what you draw in the preview window is not transferred to the document window. Also, all 
movement in the preview window will be suspended while you draw in that window.

Using the Particle tools
All Particle tools share certain basic characteristics. Perhaps the most important shared characteristic is how 
each tool is used. This brief example will outline the steps used to create images with all Particle tools. You 
should keep in mind that settings in the various tool dialogs will change the behavior of the animated images.
1. Select the desired tool by clicking on the appropriate button in the Tools palette.
You can double-click on the button to access that tool’s options dialog, where you can change the parameters of 
the effects created by the tool. The dialog settings for each tool are discussed later in this section.
2. Turn on the Record button in the Movie palette to begin recording the Particle tool actions.
You can also turn the Record option on after you have drawn the image in the document window. Either way will 
produce the same results.
You can also use the Alt-Step method of advancing or retreating across frames. You should note that using the 
Step Forward and Step Backward options to move through frames will not update the Particle tool effects unless 
the Alt key is held down while you advance to frames.
3. Draw the path for the Particle tool effect in the active document window.
You will see the dialog warning that recording paint cannot be undone. Click on the Proceed button to continue 
with the process. 
The Particle tool effect will be drawn automatically from one frame to the next as the effect progresses. If the 
Auto Advance Out Point option in the Movie menu is turned on, the effect will be continued and the Out point 
pushed back until you stop recording.
4. Click on the Stop button to end the recording.
Click on the Stop button to stop the recording or press the Escape key to pause. Remember that pressing the 
Escape key only pauses the recording. If you begin painting again in the active window, the recording will begin 
again.
5. Press the backspace key to release the final image. 
When recording the actions of any Particle tool, the final image generated by the tool while recording over time 
is still active and floating above the paint layer when the recording is ended. There is no selection border around 
the floating particles, but the uncommitted image will blink on and off to indicate it is still selected. You must 
delete that selection at the conclusion of the recording session to prevent the image from being carried back to 
the first frame and laid down on top of the Paint layer when the recording is rewound. This is a simple matter of 
pressing the Delete key immediately after the recording is stopped. If you stop the recording by pressing the 
Rewind button in the Movie palette, press the Delete key as soon as the filmstrip is rewound.
6. Click on the Rewind button in the Movie palette.
This will rewind the movie to the beginning frame.
7. Click on the Play button in the Movie palette.
The movie will advance from the beginning frame to the final frame, displaying the results of the Particle tool 
operation.
Several menu items, as well as the Hot keys, are disabled while any particle tool is active. Select another tool to 
enable these commands.

See Also
BabyBoom 



PixieDust 
SpinOut 
Squiggle 



BabyBoom

The BabyBoom tool creates particles that fly straight, spin, have trails, and are self propagating. 
You can control the movement of the particles with the Chaos slider in the tool’s dialog. The rate at which the tool 
generates particles is controlled with the Fertility slider.
The BabyBoom settings

Particle Attributes
The Particle Attributes section of the dialog establishes how the particles will look when they are created through 
two slider controls.

Size
The Size setting determines the maximum diameter (in pixels) of the BabyBoom particles. The range of this field is
0-100.

Noise
The Noise setting alters the smooth, flat texture of the standard particle to produce a non-constant, grainy 
appearance. The slider permits a range from 0-100. Lower settings produce a smoother appearance while higher 
settings result in a more grainy look.
Opacity
The Opacity dialog controls particle transparency levels. Three sliders allow you maximum control.

Inner
This control slider determines the maximum opacity at the center of each BabyBoom particle. The range of this 
setting is 1-255, with 255 being the most opaque.

Blend
Blend controls how the application smooths the transitions between the Inner and Outer opacity settings. Setting 
this field to 100, the maximum setting, adjusts the alpha of    pixels between the center of a particle and its outer 
rim to produce a smooth, graduating transition. Setting the Blend lower will harden the transition area until, at the
lowest settings, particles will have a sharp interior edge between the center and outer areas when the Inner and 
Outer values are different.

Outer
The Outer slider controls the opacity of the outermost edge of the particles. The range for this field is 0-255, with 
255 being the most opaque.
BabyBoom Settings
The BabyBoom Settings portion of the dialog establishes how particles will move and sets certain parameters for 
their creation.

Speed
The Speed slider sets the speed particles move. A low value in this field results in small steps away from the 
parent. Higher values mean larger steps, making movement from frame to frame appear faster and leaving a 
more noticeable trail.
You should note that lower settings in this field may inhibit particle trails.
The Speed can be adjusted from 0-100.

Chaos
Particle movement can be controlled with the Chaos slider. As child particles travel across the screen, their path 
randomly varies between a straight line and spinning movements. The Chaos slider establishes the extent of the 
randomization.
The slider range is 0-100. The higher the setting, the more randomized the movement variation.

Fertility
The Fertility slider controls how many generations of particles can produce their own offspring.



Increasing the number in this field permits more generations to produce their own particles. A setting of zero in 
the Fertility field means only the parent paint can produce offspring.
The maximum setting in this field is 100.

Density
The Density slider controls the flow, step, and rate of the particles. This is done through a single slider.

Flow
Flow sets the speed at which paint builds up while the cursor/brush is motionless.

Step
Step controls how far    you must move the cursor before particles are born from the parent.

Rate
The rate refers to the number of particles that are produced in each generation.

Lifespan
The Lifespan settings control how transparent particles will be when they first appear and how long they will 
remain on the screen. This is done through the Initial Birth Opacity, Life Minimum, and Life Maximum controls.

Initial Birth Opacity
This field establishes a particle’s opacity when it first appears.

Min
The Min setting establishes the minimum number of frames a particle will exist.

Max
The Max setting determines the absolute maximum number of frames a particle will exist before disappearing 
from the screen.
A particle can exist for any number of frames between the minimum and maximum life settings established in the 
dialog. The life span of each particle is assigned randomly from within the established range.

Particle Trails
The Particle Trails option checkbox allows you to turn trails on or off. Trails are dissipating particles that follow the 
path of the parent particle as it travels across the screen.

Fade Trails Alpha
This field controls the opacity of the last particle in the trail. The alpha of particles falling between the last and 
parent particles will be adjusted automatically to produce a smooth transition from the head to the tail of the 
particle trail.

Min
This sets the minimum length of the particle trail. The length is measured in particles.

Max
This field establishes the maximum length of the particle trail. Again, the length is measured in particles. The 
maximum setting in this field is 20.

Presets
The Preset button will revert all fields in the dialog to their default settings.



PixieDust
The PixieDust tool creates particles that fly mostly straight and have trails. These particles react to gravity and 
friction to produce a unique effect that will add pizzazz to your project.
The PixieDust settings

Particle attributes
The particle attributes dialog allows you to determine what the PixieDust particles will look like when they are 
created.

Size
The Size setting determines the maximum diameter (in pixels) of the PixieDust particles. The range of this field is 
0-100.

Noise
The Noise setting alters the smooth, flat texture of the standard particle to produce a non-constant, grainy 
appearance. The slider permits a range from 0-100. Lower settings produce a smoother appearance while higher 
settings result in a more grainy look.
Opacity

Inner
This control slider determines the maximum opacity at the center of each PixieDust particle. The range of this 
setting is 1-255, with 255 being the most opaque.

Blend
Blend controls how the application smooths the transitions between the Inner and Outer opacity settings.    Setting
this field to 100, the maximum setting, adjusts the alpha of    pixels between the center of a particle and its outer 
rim to produce a smooth, graduating transition. Setting the Blend lower will harden the transition area until, at the
lowest settings, particles will have a sharp interior edge between the center and outer areas when the Inner and 
Outer values are different.

Outer
The Outer slider controls the opacity of the outermost edge of the particles. The range for this field is 0-255, with 
255 being the most opaque.
PixieDust Settings
The PixieDust Settings portion of the dialog establishes how particles will move and sets certain parameters for 
their creation.

Speed
The Speed slider sets the speed particles move. A low value in this field results in small steps away from the 
parent. Higher values mean larger steps, making movement from frame to frame appear faster and leaving a 
more noticeable trail.
You should note that lower settings in this field may inhibit particle trails. The Speed can be adjusted from 0-100.

Gravity
The Gravity slider controls how fast a particle is pulled to the bottom of the screen. The higher the setting, the 
faster each particle will fall.
The range of the Gravity slider is 0-100.

Friction
The Friction slider inhibits particle velocity, slowing them once they are created. At higher settings, which creates 
the most friction to slow particles, the path of the particles may actually change.
The Friction slider has a range of 0-100

Density
The Density slider controls the flow, step, and rate of the particles. This is done through a single slider.

Flow



Flow sets the speed at which paint builds up while the cursor/brush is motionless.

Step
Step controls how far    you must move the cursor before particles are born from the parent.

Rate
The rate refers to the number of particles that are produced in each generation.

Lifespan
The Lifespan settings control how transparent particles will be when they first appear and how long they will 
remain on the screen. This is done through the Initial Birth Opacity, Life Minimum, and Life Maximum controls.

Initial Birth Opacity
This field establishes a particle’s opacity when it first appears.

Min
The Min setting establishes the minimum number of frames a particle will exist.

Max
The Max setting determines the absolute maximum number of frames a particle will exist before disappearing 
from the screen.

Particle Trails
The Particle Trails option checkbox allows you to turn trails on or off. Trails are dissipating particles that follow the 
path of the parent particle as it travels across the screen.

Fade Trails Alpha
This field controls the opacity of the last particle in the trail. The alpha of particles falling between the last and 
parent particles will be adjusted automatically to produce a smooth transition from the head to the tail of the 
particle trail.

Min
This sets the minimum length of the particle trail. The length is measured in particles.

Max
This field establishes the maximum length of the particle trail. Again, the length is measured in particles. The 
maximum setting in this field is 20.

Presets
The Preset button will revert all fields in the dialog to their default settings.



SpinOut
The SpinOut tool creates particles that can spin wildly as they travel across the screen. The particles created by 
this tool can leave trails as they travel.
The SpinOut settings

Particle attributes
The particle attributes dialog allows you to determine what the SpinOut particles will look like when they are 
created.

Size
The Size setting determines the maximum diameter (in pixels) of the SpinOut particles. The range of this field is 0-
100.

Noise
The Noise setting alters the smooth, flat texture of the standard particle to produce a non-constant, grainy 
appearance. The slider permits a range from 0-100. Lower settings produce a smoother appearance while higher 
settings result in a more grainy look.
Opacity

Inner
This control slider determines the maximum opacity at the center of each SpinOut particle. The range of this 
setting is 1-255, with 255 being the most opaque.

Blend
Blend controls how the application smooths the transitions between the Inner and Outer opacity settings.    Setting
this field to 100, the maximum setting, adjusts the alpha of    pixels between the center of a particle and its outer 
rim to produce a smooth, graduating transition. Setting the Blend lower will harden the transition area until, at the
lowest settings, particles will have a sharp interior edge between the center and outer areas when the Inner and 
Outer values are different.

Outer
The Outer slider controls the opacity of the outermost edge of the particles. The range for this field is 0-255, with 
255 being the most opaque.
SpinOut Settings
The SpinOut Settings portion of the dialog establishes how particles will move and sets certain parameters for 
their creation.

Speed
The Speed slider sets the speed particles move. A low value in this field results in small steps away from the 
parent. Higher values mean larger steps, making movement from frame to frame appear faster and leaving a 
more noticeable trail.
You should note that lower settings in this field may inhibit particle trails. The Speed can be adjusted from 0-100.

Spin
This slider controls how fast particles can spin around. A small value in this field will result in a slow spin, while 
higher settings increase the speed of the spin. The Spin slider range is 0-100.

Cluster
The Cluster slider controls how much particles will group together after their creation. A small value in this field 
will result in the particles spreading apart very quickly. Increasing the value will keep particles more tightly 
grouped.
The Cluster slider has a range of 0-100.

Density
The Density slider controls the flow, step, and rate of the particles. This is done through a single slider.

Flow



Flow sets the speed at which paint builds up while the cursor/tool is motionless.

Step
Step controls how far    you must move the cursor before particles are born from the parent.

Rate
The rate refers to the number of particles that are produced in each generation.

Rotate to the . . .
You can determine whether the particles will spin to the left or to the right through this pop-out option.

Lifespan
The Lifespan settings control how transparent particles will be when they first appear and how long they will 
remain on the screen. This is done through the Initial Birth Opacity, Life Minimum, and Life Maximum controls.

Initial Birth Opacity
This field establishes a particle’s opacity when it first appears.

Min
The Min setting establishes the minimum number of frames a particle will exist.

Max
The Max setting determines the absolute maximum number of frames a particle will exist before disappearing 
from the screen.

Particle Trails
The Particle Trails option checkbox allows you to turn trails on or off. Trails are dissipating particles that follow the 
path of the parent particle as it travels across the screen.

Fade Trails Alpha
This field controls the opacity of the last particle in the trail. The alpha of particles falling between the last and 
parent particles will be adjusted automatically to produce a smooth transition from the head to the tail of the 
particle trail.

Min
This sets the minimum length of the particle trail. The length is measured in particles.

Max
This field establishes the maximum length of the particle trail. Again, the length is measured in particles. The 
maximum setting in this field is 20.

Presets
The Preset button will revert all fields in the dialog to their default settings.



Squiggle
The Squiggle tool creates wormlike lines that wriggle and squirm on the screen. Squiggles can be connected or left
as individual points along the Squiggle path.
The Squiggle settings
Squiggle Settings
The Squiggle Settings portion of the dialog allows you to set the following attributes:

Speed
The Speed setting determines how fast, and consequently how smoothly, the Squiggles will move. The higher the 
setting in this field, the faster the Squiggles will move.
The Speed slider has a range of 1-100.

Amount
The Amount slider controls how much the Squiggles will move. Setting this field higher increases the movement, 
while lower settings inhibit movement.
The Amount slider range is 1-100.

Spacing
This slider controls how far apart moving Squiggles are. You should note this slider works in conjunction with the 
Line Spacing settings when the Connect the Squiggles checkbox in that dialog section is turned on.

Fade to Film Color
When the Fade to Film Color checkbox is turned on, you can set the amount of time in either frames or time code 
the particles will retain their original color before fading to the set Film color. Note that you can toggle between 
time code or frames with the pull-down option boxes to the right of each field.

After
Enter the number of frames or amount of time the Squiggles will retain their original color before they begin 
fading to the Film color.

Over
This field establishes how long the transformation from the Squiggles original color to the Film color will take. You 
can set this field in actual frames or time code.

Stop Squiggling
When this checkbox is turned on you can specify a time code or frame when the Squiggles will become 
motionless.

After
Enter the number of frames or the amount of time the Squiggles will move at their established pace before they 
stop moving.

Use Current Brush
When this checkbox is turned on the Squiggle tool will use the currently selected brush to draw the Squiggles. You 
should note that turning this option off toggles the Define Custom Brush option on.

Opacity
This slider allows you to adjust the opacity of the paint. The range of this field is 1-255.

Define Custom Brush

Size
The Size setting determines the maximum diameter (in pixels) of the Squiggles. The range of this field is 0-100.

Noise
The Noise setting alters the smooth, flat texture of the standard particle to produce a non-constant, grainy 
appearance. The slider permits a range from 0-100. Lower settings produce a smoother appearance while higher 



settings result in a more grainy look.
Opacity

Inner
This control slider determines the maximum opacity at the center of each Squiggle. The range of this setting is 1-
255, with 255 being the most opaque.

Blend
Blend controls how the application smoothes the transitions between the Inner and Outer opacity settings.    
Setting this field to 100, the maximum setting, adjusts the alpha of    pixels between the center of a Squiggle and 
its outer rim to produce a smooth, graduating transition. Setting the Blend lower will harden the transition area 
until, at the lowest settings, Squiggles will have a sharp interior edge between the center and outer areas when 
the Inner and Outer values are different.

Outer
The Outer slider controls the opacity of the outermost edge of the Squiggle. The range for this field is 0-255, with 
255 being the most opaque.

Line Spacing
When the Connect the Squiggles checkbox is turned on, the software will create a flexible line between brush 
footprints to form a single, squirming image.

Step
Step determines how far each footprint overlaps the next as the brush is dragged across the document window. 
The value entered here represents a percentage of the brush footprint (in pixels). 

Flow
Flow sets the speed at which paint builds up when the primary    mouse button is held down and the cursor 
remains motionless. A high Flow setting will place paint on top of paint very quickly while a low Flow setting will 
repeat laying down paint at slower intervals.

Presets
The Preset button will revert all fields in the dialog to their default settings.




